PHP 缓冲区错误漏洞

CVE编号

CVE-2019-9025

利用情况

暂无

补丁情况

N/A

披露时间

2019-02-23
漏洞描述
PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHPGroup和开放源代码社区的共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。
PHP 7.3.1之前的7.3.x版本中存在安全漏洞。攻击者可借助负的参数值利用该漏洞造成内存损坏/泄露。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://bugs.php.net/bug.php?id=77367
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp storage_automation_store - -
运行在以下环境
应用 php php * From
(including)
7.3.0
Up to
(excluding)
7.3.1
CVSS3评分
9.8
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
CWE-125 跨界内存读
CWE-787 跨界内存写
阿里云安全产品覆盖情况