低危 缓冲区溢出漏洞

CVE编号

CVE-2019-9169

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-02-26
漏洞描述
在GNU C库(又名glibc或libc6)到2.29中,posix / regexec.c中的proceed_next_node通过尝试不区分大小写的正则表达式匹配来读取基于堆的缓冲区。

解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commit;h=583dd860d5b833037175247230a328f0050dbfe9
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu glibc * Up to
(including)
2.29
运行在以下环境
应用 netapp cloud_backup * -
运行在以下环境
应用 netapp ontap_select_deploy_administration_utility - -
运行在以下环境
应用 netapp steelstore_cloud_integrated_storage - -
运行在以下环境
系统 amazon_2 glibc * Up to
(excluding)
2.26-47.amzn2
运行在以下环境
系统 centos_8 glibc * Up to
(excluding)
2.28-151.el8
运行在以下环境
系统 debian_9 glibc * Up to
(excluding)
2.24-11+deb9u4
运行在以下环境
系统 oracle_8 glibc * Up to
(excluding)
2.28-151.0.1.el8
运行在以下环境
系统 redhat_8 glibc * Up to
(excluding)
2.28-151.el8
运行在以下环境
系统 suse_12_SP4 glibc * Up to
(excluding)
2.22-100.8.1
运行在以下环境
系统 ubuntu_16.04 glibc * Up to
(excluding)
2.23-0ubuntu11.2
运行在以下环境
系统 ubuntu_18.04 glibc * Up to
(excluding)
2.27-3ubuntu1.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况