低危 pngex.cc中png_compress中的整数溢出

CVE编号

CVE-2019-9210

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-02-28
漏洞描述
在AdvanceCOMP 2.1中,当遇到无效的PNG size时,在appx.cc中的png_compress中,在advpng中有一个整数溢出,导致尝试的memcpy写入一个太小的缓冲区。 (还有一个基于堆的缓冲区过读。)

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 advancemame advancecomp 2.1 -
运行在以下环境
系统 redhat_7 advancecomp * Up to
(excluding)
0:1.15-22.el7
运行在以下环境
系统 ubuntu_14.04_lts advancecomp * Up to
(excluding)
1.18-1ubuntu0.2
运行在以下环境
系统 ubuntu_16.04_lts advancecomp * Up to
(excluding)
1.20-1ubuntu0.2
运行在以下环境
系统 ubuntu_18.04_lts advancecomp * Up to
(excluding)
2.1-1ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.10 advancecomp * Up to
(excluding)
2.1-1ubuntu0.18.10.1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况