低危 php:跨文件系统重命名文件可能允许在处理期间进行不必要的访问

CVE编号

CVE-2019-9637

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-03-09
漏洞描述
在7.1.2之前的PHP,7.2.16之前的7.2.x和7.3.3之前的7.3.x中发现了一个问题。由于实现了跨文件系统的rename() 方式,重命名的文件可能在重命名正在进行时短暂可用,但是允许未经授权的用户访问数据。

解决建议
厂商已发布漏洞修复程序,请及时关注更新:https://gist.github.com/smalyshev/4198b4573b002884ff552cffccbf050a
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp storage_automation_store - -
运行在以下环境
应用 php php * Up to
(excluding)
7.1.27
运行在以下环境
应用 php php * From
(including)
7.2.0
Up to
(excluding)
7.2.16
运行在以下环境
应用 php php * From
(including)
7.3.0
Up to
(excluding)
7.3.3
运行在以下环境
系统 alpine_3.10 php7 * Up to
(excluding)
7.2.16-r0
运行在以下环境
系统 alpine_3.11 php7 * Up to
(excluding)
7.2.16-r0
运行在以下环境
系统 alpine_3.12 php7 * Up to
(excluding)
7.2.16-r0
运行在以下环境
系统 alpine_3.13 php7 * Up to
(excluding)
7.2.16-r0
运行在以下环境
系统 alpine_3.14 php7 * Up to
(excluding)
7.2.16-r0
运行在以下环境
系统 alpine_3.15 php7 * Up to
(excluding)
7.2.16-r0
运行在以下环境
系统 alpine_3.7 php7 * Up to
(excluding)
7.1.29-r0
运行在以下环境
系统 alpine_3.8 php7 * Up to
(excluding)
7.2.17-r0
运行在以下环境
系统 alpine_3.9 php7 * Up to
(excluding)
7.2.17-r0
运行在以下环境
系统 alpine_edge php7 * Up to
(excluding)
7.2.16-r0
运行在以下环境
系统 amazon_AMI php7 * Up to
(excluding)
7.3.4-1.14.amzn1
运行在以下环境
系统 centos_8 php7 * Up to
(excluding)
5.1.12-2.module+el8.1.0+3202+af5476b9
运行在以下环境
系统 debian_8 php7 * Up to
(excluding)
5.6.20+dfsg-0+deb8u1
运行在以下环境
系统 debian_9 php7 * Up to
(excluding)
7.0.33-0+deb9u3
运行在以下环境
系统 opensuse_Leap_15.0 php7 * Up to
(excluding)
7.2.5-lp150.2.19.1
运行在以下环境
系统 opensuse_Leap_15.1 php7 * Up to
(excluding)
7.2.5-lp151.6.3.1
运行在以下环境
系统 opensuse_Leap_42.3 php7 * Up to
(excluding)
5.5.14-118.1
运行在以下环境
系统 oracle_8 php7 * Up to
(excluding)
7.2.24-1.module+el8.2.0+5510+6771133c
运行在以下环境
系统 redhat_8 php7 * Up to
(excluding)
5.1.12-2.module+el8.1.0+3202+af5476b9
运行在以下环境
系统 suse_11_SP4 php7 * Up to
(excluding)
5.3.17-112.58.1
运行在以下环境
系统 ubuntu_14.04 php7 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.29
运行在以下环境
系统 ubuntu_16.04 php7 * Up to
(excluding)
7.0.33-0ubuntu0.16.04.3
运行在以下环境
系统 ubuntu_18.04 php7 * Up to
(excluding)
7.2.15-0ubuntu0.18.04.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-264 权限、特权和访问控制
阿里云安全产品覆盖情况