低危 Jupyter Notebook up to 5.7.6 XSSI 跨站脚本攻击

CVE编号

CVE-2019-9644

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-03-12
漏洞描述
5.7.6之前的Jupyter Notebook中的XSSI(跨站点包含)漏洞允许经过Jupyter服务器验证的用户访问时,在恶意页面上包含资源。 Internet Explorer已通过捕获错误消息演示了对资源内容的访问,尽管其他浏览器未复制。发生这种情况是因为Internet Explorer的错误消息可能包含遇到的任何无效JavaScript的内容。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://blog.jupyter.org/jupyter-notebook-xssi-security-fix-546cd95babb0
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 jupyter notebook * Up to
(excluding)
5.7.6
运行在以下环境
系统 debian_9 jupyter-notebook * Up to
(including)
4.2.3-4
运行在以下环境
系统 fedora_29 jupyter-notebook * Up to
(excluding)
5.7.8-1.fc29
运行在以下环境
系统 fedora_30 jupyter-notebook * Up to
(excluding)
5.7.8-1.fc30
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况