低危 Python 至 3.7.2 ZIP Lib/zipfile.py 资源消耗漏洞

CVE编号

CVE-2019-9674

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-02-05
漏洞描述
 Python through 3.7.2中的Lib/zipfile.py允许远程攻击者通过ZIP bomb导致拒绝服务(资源消耗)。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://bugs.python.org/issue36462
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 python python * Up to
(including)
3.7.2
运行在以下环境
系统 debian_10 python2.7 * Up to
(including)
2.7.16-2+deb10u1
运行在以下环境
系统 debian_10 python3.8 * Up to
(including)
2.7.16-2+deb10u1
运行在以下环境
系统 debian_11 python2.7 * Up to
(including)
2.7.18-8
运行在以下环境
系统 debian_11 python3.8 * Up to
(including)
2.7.18-8
运行在以下环境
系统 debian_12 python * Up to
(including)
2.7.18-13.1
运行在以下环境
系统 debian_9 python2.7 * Up to
(including)
2.7.13-2+deb9u3
运行在以下环境
系统 debian_9 python3.8 * Up to
(including)
2.7.13-2+deb9u3
运行在以下环境
系统 debian_sid python2.7 * Up to
(including)
2.7.18-13.1
运行在以下环境
系统 debian_sid python3.8 * Up to
(including)
2.7.18-13.1
运行在以下环境
系统 opensuse_Leap_15.1 python2.7 * Up to
(excluding)
3.6.10-lp151.6.11.1
运行在以下环境
系统 opensuse_Leap_15.1 python3.8 * Up to
(excluding)
3.6.10-lp151.6.11.1
运行在以下环境
系统 suse_12 libpython3_4m1_0 * Up to
(excluding)
3.4.10-25.45
运行在以下环境
系统 suse_12_SP4 python2.7 * Up to
(excluding)
3.4.10-25.45.1
运行在以下环境
系统 suse_12_SP4 python3.8 * Up to
(excluding)
3.4.10-25.45.1
运行在以下环境
系统 suse_12_SP5 python2.7 * Up to
(excluding)
3.6.10-4.6.1
运行在以下环境
系统 suse_12_SP5 python3.8 * Up to
(excluding)
3.6.10-4.6.1
运行在以下环境
系统 ubuntu_14.04 python * Up to
(excluding)
3.4.3-1ubuntu1~14.04.7+esm7
运行在以下环境
系统 ubuntu_16.04 python * Up to
(excluding)
3.5.2-2ubuntu0~16.04.11
运行在以下环境
系统 ubuntu_16.04.7_lts python2.7 * Up to
(excluding)
2.7.12-1ubuntu0~16.04.12
运行在以下环境
系统 ubuntu_18.04 python * Up to
(excluding)
3.7.5-2~18.04.4
运行在以下环境
系统 ubuntu_18.04.5_lts python2.7 * Up to
(excluding)
2.7.17-1~18.04ubuntu1.1
运行在以下环境
系统 ubuntu_20.04 python * Up to
(excluding)
2.7.18-1~20.04.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-400 未加控制的资源消耗(资源穷尽)
阿里云安全产品覆盖情况