低危 libreoffice:LibreLogo是一个图形脚本,可以被操作来执行任意python命令

CVE编号

CVE-2019-9848

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-07-18
漏洞描述
LibreOffice有一个特性,文档可以指定预先安装的脚本可以在各种文档事件上执行,比如鼠标悬停等。LibreOffice通常还与LibreLogo捆绑在一起,LibreLogo是一种可编程的turtle矢量图形脚本,可以将其操作为执行任意python命令。通过使用文档事件特性来触发LibreLogo来执行包含在文档中的python,可以构造一个恶意文档,它可以在没有警告的情况下无声地执行任意python命令。在固定版本中,不能从文档事件处理程序调用LibreLogo。此问题影响:6.2.5之前的Document Foundation LibreOffice版本。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://www.libreoffice.org/about-us/security/advisories/CVE-2019-9848
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libreoffice libreoffice * Up to
(excluding)
6.2.5
运行在以下环境
系统 redhat_7 autocorr-af * Up to
(excluding)
1:5.3.6.1-24.el7
运行在以下环境
系统 suse_12 libreoffice * Up to
(excluding)
6.2.7.1-43.56
运行在以下环境
系统 ubuntu_16.04_lts libreoffice * Up to
(excluding)
1:5.1.6~rc2-0ubuntu1~xenial8
运行在以下环境
系统 ubuntu_18.04_lts libreoffice * Up to
(excluding)
1:6.0.7-0ubuntu0.18.04.8
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
CWE-94 对生成代码的控制不恰当(代码注入)
阿里云安全产品覆盖情况