低危 允许的脚本位置检查中不安全的URL程序集缺陷

CVE编号

CVE-2019-9854

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-09-07
漏洞描述
LibreOffice有一个特性,文档可以指定预先安装的宏可以在各种脚本事件上执行,比如鼠标悬停、文档打开等。访问权限被限制在LibreOffice安装的share/ scripts /python、user/ scripts /python子目录下的脚本。在address CVE-2019-9852中添加了保护,以避免目录遍历攻击,在这种攻击中,可以通过使用URL编码攻击来破坏路径验证步骤,从而执行文件系统中任意位置的脚本。但是,这种保护可以通过利用LibreOffice如何直接从传入路径的组件组装最终脚本URL位置的缺陷来绕过,而不是仅仅从路径验证步骤的经过消毒的输出来绕过。此问题影响:6.2.7之前的Document Foundation LibreOffice 6.2版本; 6.3之前的6.3版本。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://www.libreoffice.org/about-us/security/advisories/CVE-2019-9854/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libreoffice libreoffice * From
(including)
6.2.0
Up to
(excluding)
6.2.7
运行在以下环境
应用 libreoffice libreoffice * From
(including)
6.3.0
Up to
(excluding)
6.3.1
运行在以下环境
系统 redhat_7 autocorr-af * Up to
(excluding)
1:5.3.6.1-24.el7
运行在以下环境
系统 suse_12 libreoffice * Up to
(excluding)
6.2.7.1-43.56
运行在以下环境
系统 ubuntu_16.04_lts libreoffice * Up to
(excluding)
1:5.1.6~rc2-0ubuntu1~xenial10
运行在以下环境
系统 ubuntu_18.04_lts libreoffice * Up to
(excluding)
1:6.0.7-0ubuntu0.18.04.10
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-22 对路径名的限制不恰当(路径遍历)
阿里云安全产品覆盖情况