中危 Bash 任意命令执行安全漏洞

CVE编号

CVE-2019-9924

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-03-22
漏洞描述
Bash是一款为GNU计划而编写的、运行于类Unix操作系统中的Shell(命令语言解释器)。Bash 4.4-beta2之前版本,由于rbash未阻止shell用户修改BASH_CMDS,可使攻击者以shell权限执行任意命令。

解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://git.savannah.gnu.org/cgit/bash.git/tree/CHANGES?h=bash-4.4-testing#n65https://bugs.launchpad.net/ubuntu/+source/bash/+bug/1803441https://lists.debian.org/debian-lts-announce/2019/03/msg00028.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu bash * Up to
(excluding)
4.4
运行在以下环境
应用 gnu bash 4.4 -
运行在以下环境
系统 redhat_7 bash * Up to
(excluding)
0:4.2.46-34.el7
运行在以下环境
系统 suse_12 bash-lang * Up to
(excluding)
4.3-83.23
运行在以下环境
系统 ubuntu_14.04_lts bash * Up to
(excluding)
4.3-7ubuntu1.8+esm1
运行在以下环境
系统 ubuntu_16.04.7_lts bash * Up to
(excluding)
4.3-14ubuntu1.4
运行在以下环境
系统 ubuntu_16.04_lts bash * Up to
(excluding)
4.3-14ubuntu1.4
运行在以下环境
系统 ubuntu_18.04.5_lts bash * Up to
(excluding)
4.4.18-2ubuntu1
运行在以下环境
系统 ubuntu_18.04_lts bash * Up to
(excluding)
4.4.18-2ubuntu1
阿里云评分
6.0
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    服务器失陷
  • 全网数量
    10000
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
CWE-862 授权机制缺失
阿里云安全产品覆盖情况