低危 Ansible信息泄露漏洞

CVE编号

CVE-2020-10685

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-05-12
漏洞描述
Ansible是美国Ansible公司的一款计算机系统配置管理器。该产品可用于发布、管理和编排计算机系统。Ansible Tower是其中的一个提供了用户界面(UI)、仪表板和REST API的任务控制应用程序。Ansible Engine是其中的一个Ansible引擎。 Ansible中存在安全漏洞,该漏洞源于程序没有正确清理使用Vault加密文件的模块。攻击者可利用该漏洞获取敏感信息。以下产品及版本受到影响:Ansible Engine 2.7.16及之前版本,2.8.10及之前版本,2.9.6及之前版本;Ansible Tower 3.4.5及之前版本,3.5.5及之前版本,3.6.3及之前版本。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/ansible/ansible/pull/68433
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible_engine * From
(including)
2.7.0
Up to
(excluding)
2.7.17
运行在以下环境
应用 redhat ansible_engine * From
(including)
2.8.0
Up to
(excluding)
2.8.11
运行在以下环境
应用 redhat ansible_engine * From
(including)
2.9.0
Up to
(excluding)
2.9.7
运行在以下环境
应用 redhat ansible_tower * Up to
(including)
3.4.5
运行在以下环境
应用 redhat ansible_tower * From
(including)
3.5.0
Up to
(including)
3.5.5
运行在以下环境
应用 redhat ansible_tower * From
(including)
3.6.0
Up to
(including)
3.6.3
运行在以下环境
应用 redhat ceph_storage 2.0 -
运行在以下环境
应用 redhat ceph_storage 3.0 -
运行在以下环境
应用 redhat openstack 10 -
运行在以下环境
应用 redhat openstack 13.0 -
运行在以下环境
应用 redhat openstack 15.0 -
运行在以下环境
应用 redhat storage 3.0 -
运行在以下环境
系统 debian_10 ansible * Up to
(excluding)
2.7.7+dfsg-1+deb10u1
运行在以下环境
系统 debian_9 ansible * Up to
(excluding)
2.2.1.0-2+deb9u1
运行在以下环境
系统 fedora_30 ansible * Up to
(excluding)
2.9.7-1.fc30
运行在以下环境
系统 fedora_31 ansible * Up to
(excluding)
2.9.7-1.fc31
运行在以下环境
系统 fedora_32 ansible * Up to
(excluding)
2.9.7-1.fc32
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.9.7-1.el7
运行在以下环境
系统 fedora_EPEL_8 ansible * Up to
(excluding)
2.9.7-1.el8
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-377 不安全的临时文件
CWE-459 清理环节不完整
CWE-668 将资源暴露给错误范围
阿里云安全产品覆盖情况