低危 Hibernate Validator 6.1.2.Final EL Expression 输入验证漏洞

CVE编号

CVE-2020-10693

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-05-07
漏洞描述
Hibernate Validator是一款参数校验框架。Hibernate Validator 6.1.2.Final版本中存在输入验证漏洞。Hibernate Validator 6.1.2.Final版本的消息插值处理器存在输入验证漏洞,将无效的EL表达式视为有效。攻击者可利用该漏洞在处理错误消息中的用户可控数据时绕过输入验证措施。

解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://hibernate.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 hibernate validator 6.1.2 -
运行在以下环境
应用 ibm websphere_application_server * From
(including)
17.0.0.3
Up to
(including)
20.0.0.10
运行在以下环境
应用 redhat jboss_enterprise_application_platform 7.2.0 -
运行在以下环境
应用 redhat jboss_enterprise_application_platform 7.3.0 -
运行在以下环境
应用 redhat satellite 6.8 -
运行在以下环境
应用 redhat satellite_capsule 6.8 -
运行在以下环境
系统 debian_11 libhibernate-validator-java * Up to
(including)
5.3.6-1
运行在以下环境
系统 debian_12 libhibernate-validator-java * Up to
(including)
5.3.6-2
运行在以下环境
系统 debian_sid libhibernate-validator-java * Up to
(including)
5.3.6-2
运行在以下环境
系统 redhat enterprise_linux 6.0 -
运行在以下环境
系统 redhat enterprise_linux 7.0 -
运行在以下环境
系统 redhat enterprise_linux 8.0 -
运行在以下环境
系统 unionos_20 libhibernate-validator-java * Up to
(excluding)
4.3.4-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况