低危 Linux Kernel up to 5.6 SELinux Subsystem ebitmap_netlbl_import 拒绝服务漏洞

CVE编号

CVE-2020-10711

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-05-23
漏洞描述
在5.7之前的版本的Linux内核的SELinux子系统中发现了NULL指针取消引用漏洞。通过“ ebitmap_netlbl_import”例程将商业IP安全选项(CIPSO)协议的类别位图导入SELinux可扩展位图中时,会发生此缺陷。在“ cipso_v4_parsetag_rbm”例程中处理CIPSO受限位图标记时,它设置安全属性以指示存在类别位图,即使尚未分配该位图。当将相同类别的位图导入SELinux时,此问题导致NULL指针取消引用问题。此缺陷使远程网络用户可以使系统内核崩溃,从而导致拒绝服务。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://lore.kernel.org/netdev/07d99ae197bfdb2964931201db67b6cd0b38db5b.1589276729.git.pabeni@redhat.com/T/#u
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat 3scale 2.0 -
运行在以下环境
应用 redhat openstack 13.0 -
运行在以下环境
应用 redhat virtualization_host 4.0 -
运行在以下环境
系统 debian debian_linux 10 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 linux linux_kernel * Up to
(excluding)
5.7
运行在以下环境
系统 redhat enterprise_linux 6.0 -
运行在以下环境
系统 redhat enterprise_linux 7.0 -
运行在以下环境
系统 redhat enterprise_linux 8.0 -
运行在以下环境
系统 redhat enterprise_linux_aus 7.4 -
运行在以下环境
系统 redhat enterprise_linux_server_tus 7.4 -
运行在以下环境
系统 redhat messaging_realtime_grid 2.0 -
运行在以下环境
系统 redhat_6 kernel * Up to
(excluding)
0:2.6.32-754.29.2.el6
运行在以下环境
系统 redhat_7 bpftool * Up to
(excluding)
0:3.10.0-1127.8.2.el7
运行在以下环境
系统 redhat_7 kernel-rt * Up to
(excluding)
0:3.10.0-1127.8.2.rt56.1103.el7
运行在以下环境
系统 sles_12 kernel-azure * Up to
(excluding)
4.12.14-16.16
运行在以下环境
系统 suse_12 kernel-azure * Up to
(excluding)
4.12.14-16.16
运行在以下环境
系统 ubuntu_14.04_lts linux-aws * Up to
(excluding)
4.4.0-1074.78
运行在以下环境
系统 ubuntu_16.04.7_lts linux * Up to
(excluding)
4.4.0-185.215
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.4.0-185.215
运行在以下环境
系统 ubuntu_18.04.5_lts linux * Up to
(excluding)
4.15.0-109.110
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.15.0-109.110
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-476 空指针解引用
阿里云安全产品覆盖情况