脚本引擎内存损坏漏洞

CVE编号

CVE-2020-1073

利用情况

暂无

补丁情况

N/A

披露时间

2020-06-09
漏洞描述
Microsoft ChakraCore和Microsoft Edge都是美国微软(Microsoft)公司的产品。ChakraCore是使用在Edge浏览器中的一个开源的ChakraJavaScript脚本引擎的核心部分,也可作为单独的JavaScript引擎使用。Microsoft Edge是一款Windows 10之后版本系统附带的Web浏览器。 Microsoft ChakraCore和Edge中存在远程执行代码漏洞。攻击者可利用该漏洞在当前用户的上下文中执行任意代码,导致内存损坏。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2020-1073
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 microsoft chakracore * Up to
(excluding)
1.11.20
运行在以下环境
应用 microsoft edge - -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 ceph * Up to
(excluding)
4.19.91-21.al7
运行在以下环境
系统 alpine_3.10 ceph * Up to
(excluding)
4.10.17-r0
运行在以下环境
系统 alpine_3.11 ceph * Up to
(excluding)
4.11.14-r0
运行在以下环境
系统 alpine_3.12 ceph * Up to
(excluding)
4.12.5-r0
运行在以下环境
系统 alpine_3.13 ceph * Up to
(excluding)
15.2.6-r0
运行在以下环境
系统 alpine_edge ceph * Up to
(excluding)
15.2.6-r0
运行在以下环境
系统 amazon_2 ceph * Up to
(excluding)
4.14.186-146.268.amzn2
运行在以下环境
系统 amazon_AMI ceph * Up to
(excluding)
4.14.186-110.268.amzn1
运行在以下环境
系统 centos_8 kernel * Up to
(excluding)
4.18.0-240.el8
运行在以下环境
系统 debian_10 ceph * Up to
(excluding)
4.9.5+dfsg-5
运行在以下环境
系统 debian_8 ceph * Up to
(excluding)
4.9.144-3.1~deb8u1
运行在以下环境
系统 debian_9 ceph * Up to
(excluding)
0.34.3-2
运行在以下环境
系统 fedora_30 ceph * Up to
(excluding)
3.6.10-1.fc30
运行在以下环境
系统 fedora_31 ceph * Up to
(excluding)
3.7.6-1.fc31
运行在以下环境
系统 fedora_32 ceph * Up to
(excluding)
3.8.3-1.fc32
运行在以下环境
系统 opensuse_Leap_15.1 ceph * Up to
(excluding)
1.4.6-lp151.2.3.1
运行在以下环境
系统 opensuse_Leap_15.2 ceph * Up to
(excluding)
5.3.18-lp152.26.2
运行在以下环境
系统 oracle_6 ceph * Up to
(excluding)
4.1.12-124.43.4.el6uek
运行在以下环境
系统 oracle_7 ceph * Up to
(excluding)
4.1.12-124.42.3.el7uek
运行在以下环境
系统 oracle_8 ceph * Up to
(excluding)
0.34.5-3.el8
运行在以下环境
系统 redhat_7 bpftool * Up to
(excluding)
0:3.10.0-1160.el7
运行在以下环境
系统 redhat_8 kernel * Up to
(excluding)
4.18.0-240.el8
运行在以下环境
系统 suse_12 kernel-azure * Up to
(excluding)
4.12.14-16.16
运行在以下环境
系统 suse_12_SP4 ceph * Up to
(excluding)
4.12.14-6.43.1
运行在以下环境
系统 suse_12_SP5 ceph * Up to
(excluding)
4.12.14-16.16.1
运行在以下环境
系统 ubuntu_16.04.7_lts linux * Up to
(excluding)
4.4.0-186.216
运行在以下环境
系统 ubuntu_18.04.5_lts linux * Up to
(excluding)
4.15.0-115.116
CVSS3评分
8.1
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况