低危 .NET Core 和 .NET Framework 拒绝服务漏洞

CVE编号

CVE-2020-1108

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-05-12
漏洞描述
Microsoft .NET Core和Microsoft .NET Framework都是美国微软(Microsoft)公司的产品。.NET Core是一套免费的开源开发平台。该平台具有多语言支持和跨平台等特点。Microsoft .NET Framework是一种全面且一致的编程模型,也是一个用于构建Windows、Windows Store、Windows Phone、Windows Server和Microsoft Azure的应用程序的开发平台。该平台包括C#和Visual Basic编程语言、公共语言运行库和广泛的类库。 Microsoft .NET Core和.NET Framework中存在安全漏洞,该漏洞源于程序没有正确处理Web请求。攻击者可借助特制的请求利用该漏洞导致拒绝服务。以下产品及版本受到影响:Microsoft .NET Framework 4.8版本,4.7.2版本,4.7.1版本,4.7版本,4.6.2版本,4.6.1版本,4.6版本,4.5.2版本,3.5.1版本,3.5版本,3.0版本,2.0版本。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://portal.msrc.microsoft.com/zh-CN/security-guidance/advisory/CVE-2020-1108
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 microsoft .net_core * From
(including)
2.1
Up to
(including)
2.1.18
运行在以下环境
应用 microsoft .net_core * From
(including)
3.0
Up to
(including)
3.1.4
运行在以下环境
应用 microsoft .net_core 2.1 -
运行在以下环境
应用 microsoft .net_core 3.1 -
运行在以下环境
应用 microsoft .net_core 5.0.0 -
运行在以下环境
应用 microsoft .net_framework 2.0 -
运行在以下环境
应用 microsoft .net_framework 3.0 -
运行在以下环境
应用 microsoft .net_framework 3.5 -
运行在以下环境
应用 microsoft .net_framework 3.5.1 -
运行在以下环境
应用 microsoft .net_framework 4.5.2 -
运行在以下环境
应用 microsoft .net_framework 4.6 -
运行在以下环境
应用 microsoft .net_framework 4.6.1 -
运行在以下环境
应用 microsoft .net_framework 4.6.2 -
运行在以下环境
应用 microsoft .net_framework 4.7 -
运行在以下环境
应用 microsoft .net_framework 4.7.1 -
运行在以下环境
应用 microsoft .net_framework 4.7.2 -
运行在以下环境
应用 microsoft .net_framework 4.8 -
运行在以下环境
应用 microsoft powershell 7.0 -
运行在以下环境
应用 microsoft powershell_core 6.2 -
运行在以下环境
应用 microsoft visual_studio_2017 15.9 -
运行在以下环境
应用 microsoft visual_studio_2019 16.0 -
运行在以下环境
应用 microsoft visual_studio_2019 16.4 -
运行在以下环境
应用 microsoft visual_studio_2019 16.5 -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 nodejs * Up to
(excluding)
2.1.1-2.1.al7
运行在以下环境
系统 alpine_3.10 nodejs * Up to
(excluding)
1.39.2-r1
运行在以下环境
系统 alpine_3.11 nodejs * Up to
(excluding)
1.40.0-r1
运行在以下环境
系统 alpine_3.12 nodejs * Up to
(excluding)
12.18.3-r0
运行在以下环境
系统 alpine_3.13 nodejs * Up to
(excluding)
12.18.0-r0
运行在以下环境
系统 alpine_3.9 nodejs * Up to
(excluding)
1.35.1-r2
运行在以下环境
系统 alpine_edge nodejs * Up to
(excluding)
12.18.0-r0
运行在以下环境
系统 amazon_2 nodejs * Up to
(excluding)
2.1.1-2.amzn2
运行在以下环境
系统 amazon_AMI nodejs * Up to
(excluding)
1.33.0-1.1.6.amzn1
运行在以下环境
系统 centos_8 nodejs * Up to
(excluding)
10.21.0-3.module+el8.2.0+7071+d2377ea3
运行在以下环境
系统 debian_10 nodejs * Up to
(excluding)
1.36.0-2+deb10u1
运行在以下环境
系统 debian_9 nodejs * Up to
(excluding)
1.18.1-1+deb9u2
运行在以下环境
系统 fedora_31 nodejs * Up to
(excluding)
1.41.0-1.fc31
运行在以下环境
系统 fedora_32_Modular nodejs * Up to
(excluding)
14-3220201203015508.43bbeeef
运行在以下环境
系统 fedora_33 nodejs * Up to
(excluding)
14.15.1-1.fc33
运行在以下环境
系统 fedora_33_Modular nodejs * Up to
(excluding)
14-3320201203015508.601d93de
运行在以下环境
系统 fedora_EPEL_7 nodejs * Up to
(excluding)
1.33.0-1.1.el7
运行在以下环境
系统 opensuse_Leap_15.1 nodejs * Up to
(excluding)
8.17.0-lp151.2.15.1
运行在以下环境
系统 opensuse_Leap_15.2 nodejs * Up to
(excluding)
14-1.40.0-lp152.2.6.1
运行在以下环境
系统 oracle_7 nodejs * Up to
(excluding)
2.1.1-2.el7
运行在以下环境
系统 oracle_8 nodejs * Up to
(excluding)
1.33.0-3.el8_2.1
运行在以下环境
系统 redhat_8 nodejs * Up to
(excluding)
10.21.0-3.module+el8.2.0+7071+d2377ea3
运行在以下环境
系统 suse_12_SP5 nodejs * Up to
(excluding)
1.39.2-3.5.1
阿里云评分
3.3
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况