低危 Linux kernel 缓冲区错误漏洞

CVE编号

CVE-2020-11565

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-04-06
漏洞描述
Linux kernel是美国Linux基金会发布的开源操作系统Linux所使用的内核。
Linux kernel 5.6.2及之前版本中的mm/mempolicy.c文件的mpol_parse_str存在缓冲区错误漏洞,该漏洞源于程序没有正确处理空的节点列表。攻击者可借助特制的请求利用该漏洞执行任意代码或造成拒绝服务。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=aa9f7d5172fac9bf1f09e678c35e287a40a7b7dd
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 alibaba_cloud_linux_2.1903 linux * Up to
(excluding)
4.19.91-21.al7
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 canonical ubuntu_linux 20.04 -
运行在以下环境
系统 centos_8 linux * Up to
(excluding)
4.18.0-240.el8
运行在以下环境
系统 debian_10 linux * Up to
(excluding)
4.19.98-1+deb10u1
运行在以下环境
系统 debian_8 linux * Up to
(excluding)
3.16.57-1
运行在以下环境
系统 debian_9 linux * Up to
(excluding)
4.9.210-1+deb9u1
运行在以下环境
系统 linux linux_kernel * Up to
(including)
5.6.2
运行在以下环境
系统 oracle linux_7 linux * Up to
(excluding)
3.10.0-1160.el7
运行在以下环境
系统 oracle_7 linux * Up to
(excluding)
3.10.0-1160.el7
运行在以下环境
系统 oracle_8 linux * Up to
(excluding)
4.18.0-240.el8
运行在以下环境
系统 redhat_7 bpftool * Up to
(excluding)
0:3.10.0-1160.el7
运行在以下环境
系统 redhat_7 kernel-rt * Up to
(excluding)
0:3.10.0-1160.rt56.1131.el7
运行在以下环境
系统 redhat_8 linux * Up to
(excluding)
4.18.0-240.el8
运行在以下环境
系统 ubuntu_14.04 linux * Up to
(excluding)
4.4.0-179.209~14.04.1
运行在以下环境
系统 ubuntu_14.04_lts linux-aws * Up to
(excluding)
4.4.0-1067.71
运行在以下环境
系统 ubuntu_16.04 linux * Up to
(excluding)
4.4.0-1071.78
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.4.0-179.209
运行在以下环境
系统 ubuntu_18.04 linux * Up to
(excluding)
4.15.0-1059.62
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.15.0-101.102
运行在以下环境
系统 ubuntu_20.04 linux * Up to
(excluding)
5.4.0-1011.11
阿里云评分
1.7
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    管控权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况