低危 Canonical snapd cloud-init权限不当漏洞

CVE编号

CVE-2020-11933

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-07-30
漏洞描述
Canonical snapd是英国科能(Canonical)公司的一套软件部署和包管理系统。cloud-init是其中的一个主要用于实现对CVM实例初始化操作的组件。<br />
Canonical snapd(Ubuntu Core 16版本和Ubuntu Core 18版本)中的cloud-init存在权限不当漏洞。攻击者可借助特制的cloud-init用户数据/元数据利用该漏洞在设备上执行任意更改,并绕过安全机制。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 canonical ubuntu_linux 19.10 -
运行在以下环境
系统 canonical ubuntu_linux 20.04 -
运行在以下环境
系统 fedora_31 snap-confine * Up to
(excluding)
2.45.2-1.fc31
运行在以下环境
系统 fedora_31 snapd * Up to
(excluding)
2.45.2-1.fc31
运行在以下环境
系统 fedora_31 snapd-debuginfo * Up to
(excluding)
2.45.2-1.fc31
运行在以下环境
系统 fedora_31 snapd-devel * Up to
(excluding)
2.45.2-1.fc31
运行在以下环境
系统 fedora_31 snapd-selinux * Up to
(excluding)
2.45.2-1.fc31
运行在以下环境
系统 fedora_32 snap-confine * Up to
(excluding)
2.45.2-1.fc32
运行在以下环境
系统 fedora_32 snapd * Up to
(excluding)
2.45.2-1.fc32
运行在以下环境
系统 fedora_32 snapd-debuginfo * Up to
(excluding)
2.45.2-1.fc32
运行在以下环境
系统 fedora_32 snapd-devel * Up to
(excluding)
2.45.2-1.fc32
运行在以下环境
系统 fedora_32 snapd-selinux * Up to
(excluding)
2.45.2-1.fc32
运行在以下环境
系统 fedora_EPEL_7 snap-confine * Up to
(excluding)
2.45.2-1.el7
运行在以下环境
系统 fedora_EPEL_7 snapd * Up to
(excluding)
2.45.2-1.el7
运行在以下环境
系统 fedora_EPEL_7 snapd-debuginfo * Up to
(excluding)
2.45.2-1.el7
运行在以下环境
系统 fedora_EPEL_7 snapd-devel * Up to
(excluding)
2.45.2-1.el7
运行在以下环境
系统 fedora_EPEL_7 snapd-selinux * Up to
(excluding)
2.45.2-1.el7
运行在以下环境
系统 fedora_EPEL_8 snap-confine * Up to
(excluding)
2.45.2-1.el8
运行在以下环境
系统 fedora_EPEL_8 snapd * Up to
(excluding)
2.45.2-1.el8
运行在以下环境
系统 fedora_EPEL_8 snapd-debuginfo * Up to
(excluding)
2.45.2-1.el8
运行在以下环境
系统 fedora_EPEL_8 snapd-devel * Up to
(excluding)
2.45.2-1.el8
运行在以下环境
系统 fedora_EPEL_8 snapd-selinux * Up to
(excluding)
2.45.2-1.el8
阿里云评分
2.6
  • 攻击路径
    物理
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-269 特权管理不恰当
NVD-CWE-Other
阿里云安全产品覆盖情况