低危 Apache Ant注入漏洞

CVE编号

CVE-2020-11979

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-10-02 09:15:00
漏洞描述
Apache Ant是美国阿帕奇软件(Apache Software)基金会的一套用于Java软件开发的自动化工具。该工具主要用于软件的编译、测试和部署等。 Apache Ant 1.10.8版本存在注入漏洞。该漏洞源于用户输入构造命令、数据结构或记录的操作过程中,网络系统或产品缺乏对用户输入数据的正确验证,未过滤或未正确过滤掉其中的特殊元素,导致系统或产品产生解析或解释方式错误。

解决建议

目前厂商已发布升级补丁以修复漏洞,补丁获取链接: https://lists.apache.org/thread.html/r107ea1b1a7a214bc72fe1a04207546ccef542146ae22952e1013b5cc@%3Cdev.creadur.apache.org%3E


受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache ant 1.10.8 -
运行在以下环境
系统 alpine_3.11 apache-ant * Up to
(excluding)
1.10.9-r0
运行在以下环境
系统 alpine_3.12 apache-ant * Up to
(excluding)
1.10.9-r0
运行在以下环境
系统 alpine_3.13 apache-ant * Up to
(excluding)
1.10.9-r0
运行在以下环境
系统 alpine_3.14 ant * Up to
(excluding)
1.10.9-r0
运行在以下环境
系统 alpine_3.15 ant * Up to
(excluding)
1.10.9-r0
运行在以下环境
系统 alpine_edge apache-ant * Up to
(excluding)
1.10.9-r0
运行在以下环境
系统 fedora_31 apache-ant * Up to
(excluding)
1.10.9-1.fc31
运行在以下环境
系统 fedora_32 apache-ant * Up to
(excluding)
1.10.9-1.fc32
运行在以下环境
系统 fedora_33 apache-ant * Up to
(excluding)
1.10.9-1.fc33
运行在以下环境
系统 unionos_20 ant * Up to
(excluding)
1.10.5-2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-74 输出中的特殊元素转义处理不恰当(注入)
NVD-CWE-Other
阿里云安全产品覆盖情况