低危 Apache HTTP Server拒绝服务漏洞

CVE编号

CVE-2020-11993

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-08-08
漏洞描述
Apache HTTP Server是美国阿帕奇软件(Apache Software)基金会的一款开源网页服务器。该服务器具有快速、可靠且可通过简单的API进行扩充的特点。<br />
Apache HTTP Server 2.4.20版本至2.4.43版本存在拒绝服务漏洞。该漏洞源于程序未对某些日志记录语句进行正确处理。攻击者可利用该漏洞造成程序崩溃,导致拒绝服务。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2020-11993
参考链接
http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00068.html
http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00071.html
http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00081.html
http://packetstormsecurity.com/files/160393/Apache-2-HTTP2-Module-Concurrent-...
https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2020-11993
https://lists.apache.org/thread.html/r06f0d87ebb6d59ed8379633f36f72f5b1f79cad...
https://lists.apache.org/thread.html/r09bb998baee74a2c316446bd1a41ae7f8d7049d...
https://lists.apache.org/thread.html/r2c6083f6a2027914a0f5b54e2a1f4fa98c03f86...
https://lists.apache.org/thread.html/r3c5c3104813c1c5508b55564b66546933079250...
https://lists.apache.org/thread.html/r5debe8f82728a00a4a68bc904dd6c35423bdfc8...
https://lists.apache.org/thread.html/r623de9b2b2433a87f3f3a15900419fc9c00c77b...
https://lists.apache.org/thread.html/r76142b8c5119df2178be7c2dba88fde552eedee...
https://lists.apache.org/thread.html/r9e9f1a7609760f0f80562eaaec2aa3c32d525c3...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/rc998b18880df98bafaade071346690c2bc1444a...
https://lists.apache.org/thread.html/rdf3e5d0a5f5c3d90d6013bccc6c4d5af59cf1f8...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://lists.apache.org/thread.html/rf71eb428714374a6f9ad68952e23611ec7807b0...
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://security.gentoo.org/glsa/202008-04
https://security.netapp.com/advisory/ntap-20200814-0005/
https://usn.ubuntu.com/4458-1/
https://www.debian.org/security/2020/dsa-4757
https://www.oracle.com/security-alerts/cpujan2021.html
https://www.oracle.com/security-alerts/cpuoct2020.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server * From
(including)
2.4.20
Up to
(including)
2.4.43
运行在以下环境
系统 alpine_3.10 httpd * Up to
(excluding)
2.4.46-r0
运行在以下环境
系统 alpine_3.11 httpd * Up to
(excluding)
2.4.46-r0
运行在以下环境
系统 alpine_3.12 httpd * Up to
(excluding)
2.4.46-r0
运行在以下环境
系统 alpine_3.13 httpd * Up to
(excluding)
2.4.46-r0
运行在以下环境
系统 alpine_3.14 httpd * Up to
(excluding)
2.4.46-r0
运行在以下环境
系统 alpine_3.15 httpd * Up to
(excluding)
2.4.46-r0
运行在以下环境
系统 alpine_3.16 httpd * Up to
(excluding)
2.4.46-r0
运行在以下环境
系统 alpine_3.9 httpd * Up to
(excluding)
2.4.46-r0
运行在以下环境
系统 alpine_edge httpd * Up to
(excluding)
2.4.46-r0
运行在以下环境
系统 amazon_2 httpd * Up to
(excluding)
2.4.46-1.amzn2
运行在以下环境
系统 amazon_AMI httpd * Up to
(excluding)
2.4.46-1.90.amzn1
运行在以下环境
系统 centos_8 httpd * Up to
(excluding)
2.4.37-39.module+el8.4.0+9658+b87b2deb
运行在以下环境
系统 debian_10 httpd * Up to
(excluding)
2.4.38-3+deb10u4
运行在以下环境
系统 debian_9 httpd * Up to
(including)
2.4.25-3+deb9u9
运行在以下环境
系统 fedora_31 httpd * Up to
(excluding)
1.15.14-1.fc31
运行在以下环境
系统 fedora_32 httpd * Up to
(excluding)
1.15.14-1.fc32
运行在以下环境
系统 opensuse_Leap_15.1 httpd * Up to
(excluding)
2.4.33-lp151.8.15.1
运行在以下环境
系统 opensuse_Leap_15.2 httpd * Up to
(excluding)
2.4.43-lp152.2.3.1
运行在以下环境
系统 oracle_8 httpd * Up to
(excluding)
2.4.37-39.0.1.module+el8.4.0+20024+b87b2deb
运行在以下环境
系统 redhat_8 httpd * Up to
(excluding)
2.4.37-39.module+el8.4.0+9658+b87b2deb
运行在以下环境
系统 suse_12_SP5 httpd * Up to
(excluding)
2.4.23-29.63.1
运行在以下环境
系统 ubuntu_18.04 httpd * Up to
(excluding)
2.4.29-1ubuntu4.14
运行在以下环境
系统 ubuntu_18.04.5_lts apache2 * Up to
(excluding)
2.4.29-1ubuntu4.14
运行在以下环境
系统 ubuntu_20.04 httpd * Up to
(excluding)
2.4.41-4ubuntu3.1
运行在以下环境
系统 unionos_20 httpd * Up to
(excluding)
2.4.38-3+deb10u4
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-444 HTTP请求的解释不一致性(HTTP请求私运)
阿里云安全产品覆盖情况