低危 D-BUS 安全漏洞

CVE编号

CVE-2020-12049

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-06-09
漏洞描述
D-BUS是一种消息总线系统,它主要用于进程间通信及远程过程调用等。 D-BUS 1.3.0及之后版本中存在安全漏洞,该漏洞源于dbus-daemon中使用的libdbus的DBusServer,在消息超过每个消息文件描述符限制时会泄漏文件描述符。本地攻击者可利用该漏洞使系统服务达到其文件描述符限制,从而无法为后续D-Bus客户端提供服务。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://www.freedesktop.org/wiki/Software/dbus/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 freedesktop dbus * From
(including)
1.3.0
Up to
(excluding)
1.12.18
运行在以下环境
系统 redhat_7 dbus * Up to
(excluding)
1:1.10.24-14.el7_8
运行在以下环境
系统 ubuntu_14.04_lts dbus * Up to
(excluding)
1.6.18-0ubuntu4.5+esm2
运行在以下环境
系统 ubuntu_16.04.7_lts dbus * Up to
(excluding)
1.10.6-1ubuntu3.6
运行在以下环境
系统 ubuntu_16.04_lts dbus * Up to
(excluding)
1.10.6-1ubuntu3.6
运行在以下环境
系统 ubuntu_18.04.5_lts dbus * Up to
(excluding)
1.12.2-1ubuntu1.2
运行在以下环境
系统 ubuntu_18.04_lts dbus * Up to
(excluding)
1.12.2-1ubuntu1.2
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-404 不恰当的资源关闭或释放
阿里云安全产品覆盖情况