低危 Grafana 至 6.7.2 column.title/cellLinkTooltip 跨站点脚本漏洞

CVE编号

CVE-2020-12245

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-04-25
漏洞描述
Grafana是Grafana实验室的一套提供可视化监控界面的开源监控工具。该工具主要用于监控和分析Graphite、InfluxDB和Prometheus等。 Grafana 6.7.3之前版本中存在跨站脚本漏洞。该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://community.grafana.com/t/release-notes-v6-7-x/27119
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 grafana grafana * Up to
(excluding)
6.7.3
运行在以下环境
系统 centos_8 dracut-saltboot * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 opensuse_Leap_15.2 dracut-saltboot * Up to
(excluding)
0.1.1590413773.a959db7-lp152.2.3.1
运行在以下环境
系统 oracle linux_8 dracut-saltboot * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 oracle_8 dracut-saltboot * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 redhat_8 dracut-saltboot * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 sles_12_SP5 dracut-saltboot * Up to
(excluding)
0.18.1-1.6.2
运行在以下环境
系统 suse_12_SP5 dracut-saltboot * Up to
(excluding)
0.18.1-1.6.2
阿里云评分
3.7
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况