低危 GraphicsMagick堆缓冲区溢出漏洞

CVE编号

CVE-2020-12672

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-05-06
漏洞描述
GraphicsMagick是一套简单的图像处理工具。该工具对图像提供尺寸调整、旋转、加亮等功能。
GraphicsMagick 1.3.35及之前版本中的oders/png.c文件的ReadMNGImage存在缓冲区错误漏洞,该漏洞源于未正确验证数据边界。攻击者可利用该漏洞执行任意代码或导致拒绝服务。

解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

http://www.graphicsmagick.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 graphicsmagick graphicsmagick * Up to
(including)
1.3.35
运行在以下环境
系统 alpine_3.12 graphicsmagick * Up to
(excluding)
1.3.35-r2
运行在以下环境
系统 alpine_3.13 graphicsmagick * Up to
(excluding)
1.3.35-r2
运行在以下环境
系统 alpine_3.14 graphicsmagick * Up to
(excluding)
1.3.35-r2
运行在以下环境
系统 alpine_3.15 graphicsmagick * Up to
(excluding)
1.3.35-r2
运行在以下环境
系统 alpine_3.16 graphicsmagick * Up to
(excluding)
1.3.35-r2
运行在以下环境
系统 alpine_edge graphicsmagick * Up to
(excluding)
1.3.35-r2
运行在以下环境
系统 debian_10 graphicsmagick * Up to
(excluding)
1.4+really1.3.35-1~deb10u2
运行在以下环境
系统 debian_8 graphicsmagick * Up to
(excluding)
1.3.20-3+deb8u2
运行在以下环境
系统 debian_9 graphicsmagick * Up to
(excluding)
1.3.30+hg15796-1~deb9u5
运行在以下环境
系统 opensuse_Leap_15.1 graphicsmagick * Up to
(excluding)
3-1.3.29-lp151.4.20.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况