低危 GNOME glib-networking 信任管理问题漏洞

CVE编号

CVE-2020-13645

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-05-29
漏洞描述
GNOME glib-networking是一款Glib(C语言编写的五个底层库的集合)的网络扩展软件包。 GNOME glib-networking 2.64.2及之前版本中存在安全漏洞,该漏洞源于如果server-identity属性为NULL,GTlsClientConnection的实现将不会验证服务器TLS证书的主机名。目前尚无此漏洞的相关信息,请随时关注CNNVD或厂商公告。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://gitlab.gnome.org/GNOME/glib-networking/-/issues/135
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnome balsa * Up to
(excluding)
2.5.11
运行在以下环境
应用 gnome balsa 2.6.0 -
运行在以下环境
应用 gnome glib-networking * Up to
(excluding)
2.62.4
运行在以下环境
应用 gnome glib-networking * From
(including)
2.64.0
Up to
(excluding)
2.64.3
运行在以下环境
应用 netapp cloud_backup - -
运行在以下环境
系统 alpine_3.12 glib-networking * Up to
(excluding)
2.64.3-r0
运行在以下环境
系统 alpine_3.13 glib-networking * Up to
(excluding)
2.64.3-r0
运行在以下环境
系统 alpine_3.14 glib-networking * Up to
(excluding)
2.64.3-r0
运行在以下环境
系统 alpine_3.15 glib-networking * Up to
(excluding)
2.64.3-r0
运行在以下环境
系统 alpine_edge glib-networking * Up to
(excluding)
2.64.3-r0
运行在以下环境
系统 debian_10 glib-networking * Up to
(excluding)
2.58.0-2+deb10u1
运行在以下环境
系统 debian_9 glib-networking * Up to
(excluding)
2.50.0-1+deb9u1
运行在以下环境
系统 fedora_31 glib-networking * Up to
(excluding)
2.62.4-1.fc31
运行在以下环境
系统 fedora_32 glib-networking * Up to
(excluding)
2.64.3-1.fc32
运行在以下环境
系统 opensuse_Leap_15.2 glib-networking * Up to
(excluding)
2.6.1-bp153.2.3.1
运行在以下环境
系统 opensuse_Leap_15.3 glib-networking * Up to
(excluding)
2.6.1-bp153.2.3.1
运行在以下环境
系统 suse_12_SP5 glib-networking * Up to
(excluding)
2.48.2-6.3.1
运行在以下环境
系统 ubuntu_16.04 glib-networking * Up to
(excluding)
2.48.2-1~ubuntu16.04.2
运行在以下环境
系统 ubuntu_18.04 glib-networking * Up to
(excluding)
2.56.0-1ubuntu0.1
运行在以下环境
系统 ubuntu_20.04 glib-networking * Up to
(excluding)
2.64.2-1ubuntu0.1
运行在以下环境
系统 unionos_20 glib-networking * Up to
(excluding)
2.58.0.1-2+deb10u2
阿里云评分
2.3
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    -
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况