低危 QEMU:ati vga:ati mm_读/写调用中的无限递归可能导致DoS

CVE编号

CVE-2020-13800

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-06-05
漏洞描述
QEMU(Quick Emulator)是法国法布里斯-贝拉(Fabrice Bellard)软件开发者的一套模拟处理器软件。该软件具有速度快、跨平台等特点。
QEMU 4.2.0版本中的 hw/display/ati.c文件的ati-vga存在安全漏洞。攻击者可借助特制mm_index值利用该漏洞导致无限递归。

解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:
https://www.qemu.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 qemu qemu 4.2.0 -
运行在以下环境
系统 alpine_3.16 qemu * Up to
(excluding)
5.0.0-r0
运行在以下环境
系统 alpine_edge qemu * Up to
(excluding)
5.0.0-r0
运行在以下环境
系统 opensuse_Leap_15.2 qemu * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-arm * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-audio-alsa * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-audio-pa * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-audio-sdl * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-block-curl * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-block-dmg * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-block-gluster * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-block-iscsi * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-block-nfs * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-block-rbd * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-block-ssh * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-extra * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-guest-agent * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-ipxe * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-ksm * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-kvm * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-lang * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-linux-user * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-microvm * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-ppc * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-s390 * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-seabios * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-sgabios * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-testsuite * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-tools * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-ui-curses * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-ui-gtk * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-ui-sdl * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-ui-spice-app * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-vgabios * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-vhost-user-gpu * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 opensuse_Leap_15.2 qemu-x86 * Up to
(excluding)
4.2.1-lp152.9.3.1
运行在以下环境
系统 ubuntu_20.04 qemu * Up to
(excluding)
1:4.2-3ubuntu6.4
运行在以下环境
系统 unionos_20 qemu * Up to
(excluding)
0
阿里云评分
2.3
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    管控权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-674 未经控制的递归
CWE-835 不可达退出条件的循环(无限循环)
阿里云安全产品覆盖情况