低危 Apache Tomcat拒绝服务漏洞

CVE编号

CVE-2020-13934

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-07-15
漏洞描述
Apache Tomcat是美国阿帕奇(Apache)软件基金会的一款轻量级Web应用服务器。该程序实现了对Servlet和JavaServer Page(JSP)的支持。 Apache Tomcat 10.0.0-M1版本至10.0.0-M6版本,9.0.0.M5版本至9.0.36版本和8.5.1版本至8.5.56中存在缓冲区错误漏洞。攻击者可借助大量请求利用该漏洞造成拒绝服务。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://lists.apache.org/thread.html/r61f411cf82488d6ec213063fc15feeeb88e31b0ca9c29652ee4f962e%40%3Cannounce.tomcat.apache.org%3E
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache tomcat * From
(including)
8.5.1
Up to
(including)
8.5.56
运行在以下环境
应用 apache tomcat * From
(including)
9.0.1
Up to
(including)
9.0.36
运行在以下环境
应用 apache tomcat 10.0.0 -
运行在以下环境
应用 apache tomcat 9.0.0 -
运行在以下环境
系统 amazon linux_AMI tomcat8 * Up to
(excluding)
8.5.57-1.85.amzn1
运行在以下环境
系统 amazon_AMI tomcat9 * Up to
(excluding)
3.1-api-8.5.57-1.85.amzn1
运行在以下环境
系统 debian_10 tomcat8 * Up to
(excluding)
9.0.31-1~deb10u2
运行在以下环境
系统 debian_9 tomcat8 * Up to
(excluding)
8.5.54-0+deb9u3
运行在以下环境
系统 opensuse_Leap_15.1 tomcat8 * Up to
(excluding)
9.0.36-lp151.3.27.1
运行在以下环境
系统 opensuse_Leap_15.2 tomcat8 * Up to
(excluding)
9.0.36-lp152.2.4.1
运行在以下环境
系统 sles_12_SP5 tomcat8 * Up to
(excluding)
9.0.36-3.45.1
运行在以下环境
系统 suse_12_SP5 tomcat9 * Up to
(excluding)
9.0.36-3.45.1
运行在以下环境
系统 ubuntu_20.04 tomcat9 * Up to
(excluding)
9.0.31-1ubuntu0.1
运行在以下环境
系统 unionos_20 tomcat9 * Up to
(excluding)
9.0.31-1~deb10u2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
CWE-401 在移除最后引用时对内存的释放不恰当(内存泄露)
CWE-476 空指针解引用
阿里云安全产品覆盖情况