DirectWrite 远程执行代码漏洞

CVE编号

CVE-2020-1409

利用情况

暂无

补丁情况

N/A

披露时间

2020-07-14
漏洞描述
Microsoft Windows是一套个人设备使用的操作系统。Microsoft Windows Server是一套服务器操作系统。DirectWrite是其中的一个文本布局和字形渲染API(应用程序编程接口)。<br />
Microsoft DirectWrite处理内存对象的方式存在远程代码执行漏洞。攻击者可利用该漏洞远程执行代码。以下产品及版本受到影响: Microsoft Office 2016、Microsoft Office 2019、Windows 10、Windows 10 1607、Windows 10 1709、Windows 10 1803、Windows 10 1809、Windows 10 1903、Windows 10 1909、Windows 10 2004、Windows 7 SP1、Windows 8.1、Windows RT 8.1、Windows Server 2008 SP2、Windows Server 2008 R2 SP1、Windows Server 2012、Windows Server 2012 R2、Windows Server 2016、Windows Server 2019、Windows Server 1903、Windows Server 1909、Windows Server 2004版本。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 alpine_3.12 mutt * Up to
(excluding)
1.14.4-r0
运行在以下环境
系统 alpine_3.13 mutt * Up to
(excluding)
1.14.4-r0
运行在以下环境
系统 alpine_edge mutt * Up to
(excluding)
1.14.4-r0
运行在以下环境
系统 debian_10 mutt * Up to
(excluding)
1.10.1-2.1+deb10u2
运行在以下环境
系统 debian_8 mutt * Up to
(excluding)
1.5.23-3+deb8u1
运行在以下环境
系统 debian_9 mutt * Up to
(excluding)
1.7.2-1+deb9u3
运行在以下环境
系统 microsoft windows_10 - -
运行在以下环境
系统 microsoft windows_10 1607 -
运行在以下环境
系统 microsoft windows_10 1709 -
运行在以下环境
系统 microsoft windows_10 1803 -
运行在以下环境
系统 microsoft windows_10 1809 -
运行在以下环境
系统 microsoft windows_10 1903 -
运行在以下环境
系统 microsoft windows_10 1909 -
运行在以下环境
系统 microsoft windows_10 2004 -
运行在以下环境
系统 microsoft windows_7 - -
运行在以下环境
系统 microsoft windows_8.1 - -
运行在以下环境
系统 microsoft windows_rt_8.1 - -
运行在以下环境
系统 microsoft windows_server_2008 - -
运行在以下环境
系统 microsoft windows_server_2008 r2 -
运行在以下环境
系统 microsoft windows_server_2012 - -
运行在以下环境
系统 microsoft windows_server_2012 r2 -
运行在以下环境
系统 microsoft windows_server_2016 - -
运行在以下环境
系统 microsoft windows_server_2016 1903 -
运行在以下环境
系统 microsoft windows_server_2016 1909 -
运行在以下环境
系统 microsoft windows_server_2016 2004 -
运行在以下环境
系统 microsoft windows_server_2019 - -
运行在以下环境
系统 opensuse_Leap_15.1 mutt * Up to
(excluding)
1.10.1-lp151.2.3.1
运行在以下环境
系统 opensuse_Leap_15.2 mutt * Up to
(excluding)
1.10.1-lp152.3.3.1
运行在以下环境
系统 sles_12_SP4 mutt * Up to
(excluding)
1.10.1-55.11.1
运行在以下环境
系统 sles_12_SP5 mutt * Up to
(excluding)
1.10.1-55.11.1
运行在以下环境
系统 ubuntu_16.04.7_lts mutt * Up to
(excluding)
1.5.24-1ubuntu0.3
运行在以下环境
系统 ubuntu_16.04_lts mutt * Up to
(excluding)
1.5.24-1ubuntu0.3
运行在以下环境
系统 ubuntu_18.04.5_lts mutt * Up to
(excluding)
1.9.4-3ubuntu0.2
运行在以下环境
系统 ubuntu_18.04_lts mutt * Up to
(excluding)
1.9.4-3ubuntu0.2
CVSS3评分
7.8
  • 攻击路径
    本地
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
NVD-CWE-noinfo
阿里云安全产品覆盖情况