低危 Prism跨站脚本漏洞

CVE编号

CVE-2020-15138

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-08-08
漏洞描述
Prism是美国Prism个人开发者的一个应用软件。是一种轻量级的,可扩展的语法突出显示工具。

Prism存在跨站脚本漏洞。攻击者可利用漏洞在Safari和Internet Explorer中执行任意代码。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/PrismJS/prism/security/advisories/GHSA-wvhm-4hhf-97x9
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apple safari - -
运行在以下环境
应用 microsoft internet_explorer - -
运行在以下环境
应用 prismjs previewers * From
(including)
1.1.0
Up to
(excluding)
1.21.0
阿里云评分
3.9
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况