低危 mariadb mariadb 输入验证不恰当

CVE编号

CVE-2020-15180

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-05-28
漏洞描述
A flaw was found in the mysql-wsrep component of mariadb. Lack of input sanitization in `wsrep_sst_method` allows for command injection that can be exploited by a remote attacker to execute arbitrary commands on galera cluster nodes. This threatens the system's confidentiality, integrity, and availability. This flaw affects mariadb versions before 10.1.47, before 10.2.34, before 10.3.25, before 10.4.15 and before 10.5.6.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 galeracluster galera_cluster_for_mysql * From
(including)
5.6
Up to
(excluding)
5.6.49
运行在以下环境
应用 galeracluster galera_cluster_for_mysql * From
(including)
5.7
Up to
(excluding)
5.7.31
运行在以下环境
应用 galeracluster galera_cluster_for_mysql * From
(including)
8.0
Up to
(excluding)
8.0.21
运行在以下环境
应用 mariadb mariadb * From
(including)
10.1.0
Up to
(excluding)
10.1.47
运行在以下环境
应用 mariadb mariadb * From
(including)
10.2.0
Up to
(excluding)
10.2.34
运行在以下环境
应用 mariadb mariadb * From
(including)
10.3.0
Up to
(excluding)
10.3.25
运行在以下环境
应用 mariadb mariadb * From
(including)
10.4.0
Up to
(excluding)
10.4.15
运行在以下环境
应用 mariadb mariadb * From
(including)
10.5.0
Up to
(excluding)
10.5.6
运行在以下环境
应用 percona xtradb_cluster * Up to
(excluding)
5.6.49-28.42.2
运行在以下环境
应用 percona xtradb_cluster * From
(including)
5.7
Up to
(excluding)
5.7.31-31.45.2
运行在以下环境
应用 percona xtradb_cluster * From
(including)
8.0
Up to
(excluding)
8.0.20-11.2
运行在以下环境
系统 alibaba_cloud_linux_2.1903 mariadb * Up to
(excluding)
10.3.27-3.1.al8
运行在以下环境
系统 alpine_3.10 mariadb * Up to
(excluding)
10.3.25-r0
运行在以下环境
系统 alpine_3.11 mariadb * Up to
(excluding)
10.4.15-r0
运行在以下环境
系统 alpine_3.12 mariadb * Up to
(excluding)
10.4.15-r0
运行在以下环境
系统 alpine_3.13 mariadb * Up to
(excluding)
10.5.6-r0
运行在以下环境
系统 alpine_3.14 mariadb * Up to
(excluding)
10.5.6-r0
运行在以下环境
系统 alpine_3.15 mariadb * Up to
(excluding)
10.5.6-r0
运行在以下环境
系统 alpine_3.16 mariadb * Up to
(excluding)
10.5.6-r0
运行在以下环境
系统 alpine_3.9 mariadb * Up to
(excluding)
10.3.25-r0
运行在以下环境
系统 alpine_edge mariadb * Up to
(excluding)
10.5.6-r0
运行在以下环境
系统 centos_8 mariadb * Up to
(excluding)
25.3.31-1.module+el8.3.0+8843+3f4e42f6
运行在以下环境
系统 debian_10 mariadb * Up to
(excluding)
1:10.3.25-0+deb10u1
运行在以下环境
系统 debian_11 mariadb * Up to
(including)
10.3.24-2
运行在以下环境
系统 debian_9 mariadb * Up to
(excluding)
10.1.47-0+deb9u1
运行在以下环境
系统 debian_sid mariadb * Up to
(including)
10.3.24-2
运行在以下环境
系统 fedora_31_Modular mariadb * Up to
(excluding)
10.3-3120201106115457.f636be4b
运行在以下环境
系统 fedora_32_Modular mariadb * Up to
(excluding)
10.3-3220201106115457.43bbeeef
运行在以下环境
系统 fedora_33_Modular mariadb * Up to
(excluding)
10.3-3320201106115457.601d93de
运行在以下环境
系统 opensuse_Leap_15.1 mariadb * Up to
(excluding)
10.2.36-lp151.2.18.1
运行在以下环境
系统 opensuse_Leap_15.2 mariadb * Up to
(excluding)
3.1.11-lp152.4.1
运行在以下环境
系统 oracle_8 mariadb * Up to
(excluding)
10.3.27-3.module+el8.3.0+7885+7a81225f
运行在以下环境
系统 redhat_8 mariadb * Up to
(excluding)
25.3.31-1.module+el8.3.0+8843+3f4e42f6
运行在以下环境
系统 suse_12_SP5 mariadb * Up to
(excluding)
10.2.36-3.33.1
运行在以下环境
系统 ubuntu_18.04 mariadb * Up to
(excluding)
1:10.1.47-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts mariadb-10.1 * Up to
(excluding)
1:10.1.47-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_20.04 mariadb * Up to
(excluding)
1:10.3.25-0ubuntu0.20.04.1
运行在以下环境
系统 unionos_20 mariadb * Up to
(excluding)
10.3.27-0+deb10u1
阿里云评分
3.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    N/A
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
CWE-96 静态存储代码中指令转义处理不恰当(静态代码注入)
阿里云安全产品覆盖情况