低危 helm helm 使用多个具有重复标识的资源

CVE编号

CVE-2020-15185

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-09-18
漏洞描述
helm是一款Kubernetes包管理器。

Helm 2.16.11之前版本和3.3.2版本存在注入漏洞,该漏洞源于用户输入构造命令、数据结构或记录的操作过程中,网络系统或产品缺乏对用户输入数据的正确验证,未过滤或未正确过滤掉其中的特殊元素,导致系统或产品产生解析或解释方式错误。远程攻击者可通过发送特制的SQL语句利用该漏洞在后台数据库中查看、添加、修改或删除后端数据库中的信息。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/helm/helm/security/advisories/GHSA-jm56-5h66-w453
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 helm helm * From
(including)
2.0.0
Up to
(excluding)
2.16.11
运行在以下环境
应用 helm helm * From
(including)
3.0.0
Up to
(excluding)
3.3.2
阿里云评分
2.7
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    管控权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-694 使用多个具有重复标识的资源
CWE-74 输出中的特殊元素转义处理不恰当(注入)
NVD-CWE-Other
阿里云安全产品覆盖情况