低危 Dogtag PKI 信任管理问题漏洞

CVE编号

CVE-2020-15720

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-07-15
漏洞描述
Dogtag PKI 10.8.3及之前版本中存在信任管理问题漏洞,该漏洞源于pki.client.PKIConnection类没有开启python请求的证书验证并且所有的请求函数都使用了硬编码的‘verify’参数。攻击者可利用该漏洞实施中间人攻击。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 dogtagpki dogtagpki * Up to
(including)
10.8.3
运行在以下环境
系统 centos_8 dogtag-pki * Up to
(excluding)
2.2.11-11.module+el8.1.0+3366+6dfb954c
运行在以下环境
系统 oracle_8 dogtag-pki * Up to
(excluding)
1.7.7-8.module+el8.3.0+7697+44932688
运行在以下环境
系统 redhat_8 dogtag-pki * Up to
(excluding)
2.10.0-1.module+el8.2.0+5059+3eb3af25
运行在以下环境
系统 ubuntu_8 dogtag-pki * Up to
(excluding)
2.2.11-11.module+el8.1.0+3366+6dfb954c
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况