低危 python python 授权机制不正确

CVE编号

CVE-2020-15801

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-07-17
漏洞描述
Python是Python软件基金会的一套开源的、面向对象的程序设计语言。该语言具有可扩展、支持模块和包、支持多种平台等特点。

Python 3.8.4版本中存在安全漏洞,该漏洞源于程序未能执行python38._pth文件中设置的sys.path限制,攻击者可利用该漏洞加载代码。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://bugs.python.org/issue41304
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 python python 3.8.4 -
运行在以下环境
系统 ubuntu_20 python2.7 * Up to
(excluding)
2.7.16-2+deb10u1
运行在以下环境
系统 unionos_20 python2.7 * Up to
(excluding)
2.7.16-2+deb10u1
阿里云评分
3.4
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-426 不可信的搜索路径
CWE-863 授权机制不正确
阿里云安全产品覆盖情况