低危 PackageKit:本地用户安装不受信任的包

CVE编号

CVE-2020-16122

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-11-07
漏洞描述
Red Hat PolicyKit(Polkit)是美国(Polkit)等都是美国红帽(Red Hat)公司的产品。PolicyKit是一个用于在Unix兼容系统中对应用程序进行权限控制的工具。PackageKit等都是的产品。PackageKit的apt后端错误地将所有本地DEB视为可信。apt安全模型基于存储库信任,而不是基于单个文件的内容。配置为允许用户在此PolicyKit网站上安装恶意程序包的规则。

解决建议

目前厂商已发布升级补丁以修复漏洞,补丁获取链接: https://ubuntu.com/security/notices/USN-4538-1


受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 freedesktop packagekit - -
运行在以下环境
系统 debian_10 packagekit * Up to
(excluding)
1.1.12-5
运行在以下环境
系统 debian_9 packagekit * Up to
(excluding)
1.1.5-2+deb9u2
运行在以下环境
系统 ubuntu_16.04 packagekit * Up to
(excluding)
0.8.17-4ubuntu6~gcc5.4ubuntu1.5
运行在以下环境
系统 ubuntu_18.04 packagekit * Up to
(excluding)
1.1.9-1ubuntu2.18.04.6
运行在以下环境
系统 ubuntu_20.04 packagekit * Up to
(excluding)
1.1.13-2ubuntu1.1
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-269 特权管理不恰当
NVD-CWE-noinfo
阿里云安全产品覆盖情况