低危 Linux kernel 信息泄露漏洞

CVE编号

CVE-2020-16166

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-07-31
漏洞描述
Linux kernel是美国Linux基金会发布的开源操作系统Linux所使用的内核。
Linux内核5.7.11允许远程攻击者进行观察,帮助获取有关网络RNG内部状态的敏感信息,即CID-f227e3ec3b5c。这与drivers/char/random.c和kernel/time/timer.c有关。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/torvalds/linux/commit/f227e3ec3b5cad859ad15666874405e8c1bbc1d4
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp active_iq_unified_manager * From
(including)
9.5
运行在以下环境
应用 netapp cloud_volumes_ontap_mediator - -
运行在以下环境
应用 netapp e-series_santricity_os_controller * From
(including)
11.0.0
Up to
(including)
11.60.3
运行在以下环境
应用 netapp hci_bootstrap_os - -
运行在以下环境
应用 netapp hci_management_node - -
运行在以下环境
应用 netapp solidfire - -
运行在以下环境
应用 netapp steelstore_cloud_integrated_storage - -
运行在以下环境
应用 netapp storagegrid * Up to
(including)
9.0.4
运行在以下环境
系统 alibaba_cloud_linux_2.1903 linux * Up to
(excluding)
4.19.91-22.al7
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 canonical ubuntu_linux 20.04 -
运行在以下环境
系统 centos_8 linux * Up to
(excluding)
4.18.0-240.8.1.el8_3
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_10 linux * Up to
(excluding)
4.19.146-1
运行在以下环境
系统 debian_9 linux * Up to
(excluding)
4.9.240-1
运行在以下环境
系统 fedoraproject fedora 31 -
运行在以下环境
系统 fedoraproject fedora 32 -
运行在以下环境
系统 fedora_31 linux * Up to
(excluding)
5.7.15-100.fc31
运行在以下环境
系统 fedora_32 linux * Up to
(excluding)
5.7.14-200.fc32
运行在以下环境
系统 linux linux_kernel * Up to
(including)
5.7.11
运行在以下环境
系统 netapp h410c_firmware - -
运行在以下环境
系统 opensuse leap 15.1 -
运行在以下环境
系统 opensuse leap 15.2 -
运行在以下环境
系统 opensuse_Leap_15.1 linux * Up to
(excluding)
4.12.14-lp151.28.59.1
运行在以下环境
系统 opensuse_Leap_15.2 linux * Up to
(excluding)
19.11.1-lp152.2.5.1
运行在以下环境
系统 oracle linux_6 linux * Up to
(excluding)
4.1.12-124.45.6.el6uek
运行在以下环境
系统 oracle linux_7 linux * Up to
(excluding)
4.1.12-124.45.6.el7uek
运行在以下环境
系统 oracle linux_8 linux * Up to
(excluding)
5.4.17-2011.6.2.el8uek
运行在以下环境
系统 oracle_6 linux * Up to
(excluding)
4.1.12-124.45.6.el6uek
运行在以下环境
系统 oracle_7 linux * Up to
(excluding)
4.1.12-124.45.6.el7uek
运行在以下环境
系统 oracle_8 linux * Up to
(excluding)
5.4.17-2011.6.2.el8uek
运行在以下环境
系统 redhat_8 linux * Up to
(excluding)
4.18.0-240.8.1.el8_3
运行在以下环境
系统 sles_12_SP5 linux * Up to
(excluding)
4.12.14-16.25.1
运行在以下环境
系统 suse_12_SP5 linux * Up to
(excluding)
4.12.14-16.25.1
运行在以下环境
系统 ubuntu_14.04 linux * Up to
(excluding)
4.15.0-1096.106~14.04.1
运行在以下环境
系统 ubuntu_14.04_lts linux-azure * Up to
(excluding)
4.15.0-1096.106~14.04.1
运行在以下环境
系统 ubuntu_16.04 linux * Up to
(excluding)
4.15.0-118.119~16.04.1
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.2.0-16.19
运行在以下环境
系统 ubuntu_18.04 linux * Up to
(excluding)
5.4.0-1026.26~18.04.1
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.15.0-118.119
运行在以下环境
系统 ubuntu_20.04 linux * Up to
(excluding)
5.4.0-1025.25
运行在以下环境
硬件 netapp h410c - -
阿里云评分
3.0
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-200 信息暴露
阿里云安全产品覆盖情况