低危 Artifex Software Ghostscript堆栈缓冲区溢出漏洞

CVE编号

CVE-2020-16304

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-08-13
漏洞描述
Artifex Software Ghostscript是美国Artifex Software公司的一款开源的PostScript(一种用于电子产业和桌面出版领域的页面描述语言和编程语言)解析器。该产品可显示Postscript文件以及在非Postscript打印机上打印Postscript文件。<br />
Artifex Software Ghostscript v9.50版本中的base/gxicolor.c文件的image_render_color_thresh()存在堆栈缓冲区溢出漏洞。远程攻击者可借助特制PDF文件利用该漏洞导致拒绝服务。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=027c546e0dd11e0526f1780a7f3c2c66acffe209
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 artifex ghostscript 9.50 -
运行在以下环境
系统 alpine_3.13 ghostscript * Up to
(excluding)
9.51-r0
运行在以下环境
系统 alpine_3.14 ghostscript * Up to
(excluding)
9.51-r0
运行在以下环境
系统 alpine_3.15 ghostscript * Up to
(excluding)
9.51-r0
运行在以下环境
系统 alpine_3.16 ghostscript * Up to
(excluding)
9.51-r0
运行在以下环境
系统 alpine_edge ghostscript * Up to
(excluding)
9.51-r0
运行在以下环境
系统 centos_8 ghostscript * Up to
(excluding)
9.27-1.el8
运行在以下环境
系统 debian_10 ghostscript * Up to
(excluding)
9.27~dfsg-2+deb10u4
运行在以下环境
系统 debian_9 ghostscript * Up to
(excluding)
9.26a~dfsg-0+deb9u7
运行在以下环境
系统 oracle_8 ghostscript * Up to
(excluding)
9.27-1.el8
运行在以下环境
系统 redhat_8 ghostscript * Up to
(excluding)
9.27-1.el8
运行在以下环境
系统 ubuntu_18.04 ghostscript * Up to
(excluding)
9.26~dfsg+0-0ubuntu0.18.04.13
运行在以下环境
系统 ubuntu_18.04.5_lts ghostscript * Up to
(excluding)
9.26~dfsg+0-0ubuntu0.18.04.13
运行在以下环境
系统 ubuntu_20.04 ghostscript * Up to
(excluding)
9.50~dfsg-5ubuntu4.2
运行在以下环境
系统 unionos_20 ghostscript * Up to
(excluding)
9.27~dfsg.1-1+dde
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况