低危 Ceph RGW Beast Disconnect Flooding 拒绝服务漏洞

CVE编号

CVE-2020-1700

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-02-08
漏洞描述
 
Ceph RGW Beast front-end  处理意外断开的方式中发现了一个漏洞。 经过身份验证的攻击者可以通过多次断开尝试滥用此缺陷,从而导致radosgw永久泄漏套接字连接。 这一缺陷可能导致由于CLOSE_WAIT套接字的堆积而导致服务条件被拒绝,最终导致可用资源枯竭,阻止合法用户连接到系统。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 ceph ceph - -
运行在以下环境
应用 redhat openshift_container_storage 4.2 -
运行在以下环境
系统 alpine_3.10 ceph * Up to
(excluding)
14.2.7-r0
运行在以下环境
系统 alpine_3.11 ceph * Up to
(excluding)
14.2.7-r0
运行在以下环境
系统 alpine_3.12 ceph * Up to
(excluding)
14.2.7-r0
运行在以下环境
系统 alpine_3.13 ceph * Up to
(excluding)
14.2.7-r0
运行在以下环境
系统 alpine_3.14 ceph * Up to
(excluding)
14.2.7-r0
运行在以下环境
系统 alpine_3.15 ceph * Up to
(excluding)
14.2.7-r0
运行在以下环境
系统 alpine_3.16 ceph * Up to
(excluding)
14.2.7-r0
运行在以下环境
系统 alpine_edge ceph * Up to
(excluding)
14.2.7-r0
运行在以下环境
系统 debian_10 ceph * Up to
(including)
12.2.11+dfsg1-2.1
运行在以下环境
系统 opensuse_Leap_15.1 ceph * Up to
(excluding)
14.2.5.382
运行在以下环境
系统 ubuntu_18.04 ceph * Up to
(excluding)
12.2.12-0ubuntu0.18.04.5
运行在以下环境
系统 ubuntu_18.04.5_lts ceph * Up to
(excluding)
12.2.12-0ubuntu0.18.04.5
运行在以下环境
系统 unionos_20 ceph * Up to
(excluding)
12.2.11+dfsg1.2-1+dde
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-400 未加控制的资源消耗(资源穷尽)
阿里云安全产品覆盖情况