低危 在版本v245-rc1之前的systemd中发现了一个堆释放后重利用漏洞

CVE编号

CVE-2020-1712

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-04-01
漏洞描述
在版本v245-rc1之前的systemd中发现了一个堆释放后使用漏洞,该漏洞在处理dbus消息时执行异步Polkit查询。本地无特权的攻击者可以通过发送特制的dbus消息来滥用此漏洞,以使系统服务崩溃或潜在地执行代码并提升其特权。

解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:
https://github.com/systemd/systemd/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 freedesktop systemd * Up to
(including)
244
运行在以下环境
应用 redhat ceph_storage 4.0 -
运行在以下环境
应用 redhat discovery - -
运行在以下环境
应用 redhat migration_toolkit 1.0 -
运行在以下环境
应用 redhat openshift_container_platform 4.0 -
运行在以下环境
系统 amazon_2 systemd * Up to
(excluding)
219-57.amzn2.0.12
运行在以下环境
系统 centos_8 systemd * Up to
(excluding)
239-18.el8_1.4
运行在以下环境
系统 debian_10 systemd * Up to
(excluding)
241-7~deb10u4
运行在以下环境
系统 debian_9 systemd * Up to
(excluding)
232-25+deb9u14
运行在以下环境
系统 fedora_30 systemd * Up to
(excluding)
241-14.git18dd3fb.fc30
运行在以下环境
系统 opensuse_Leap_15.1 systemd * Up to
(excluding)
234-lp151.26.7.1
运行在以下环境
系统 oracle_8 systemd * Up to
(excluding)
239-18.0.2.el8_1.4
运行在以下环境
系统 redhat_8 systemd * Up to
(excluding)
239-18.el8_1.4
运行在以下环境
系统 suse_12 libsystemd0-228 * Up to
(excluding)
150.82
运行在以下环境
系统 suse_12_SP4 systemd * Up to
(excluding)
228-150.82.1
运行在以下环境
系统 suse_12_SP5 systemd * Up to
(excluding)
228-157.9.1
运行在以下环境
系统 ubuntu_16.04 systemd * Up to
(excluding)
229-4ubuntu21.27
运行在以下环境
系统 ubuntu_16.04.7_lts systemd * Up to
(excluding)
229-4ubuntu21.27
运行在以下环境
系统 ubuntu_18.04 systemd * Up to
(excluding)
237-3ubuntu10.38
运行在以下环境
系统 ubuntu_18.04.5_lts systemd * Up to
(excluding)
237-3ubuntu10.38
运行在以下环境
系统 ubuntu_20.04 systemd * Up to
(excluding)
244.1-0ubuntu3
运行在以下环境
系统 ubuntu_21.04 systemd * Up to
(excluding)
244.1-0ubuntu3
运行在以下环境
系统 ubuntu_21.10 systemd * Up to
(excluding)
244.1-0ubuntu3
运行在以下环境
系统 ubuntu_22.04 systemd * Up to
(excluding)
244.1-0ubuntu3
运行在以下环境
系统 unionos_20 systemd * Up to
(excluding)
241.8.1-6+dde
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况