低危 可以根据ansible facts选择模块包

CVE编号

CVE-2020-1738

利用情况

暂无

补丁情况

临时补丁

披露时间

2020-03-17
漏洞描述
当使用模块包或服务且未指定参数“ use”时,在Ansible Engine中发现一个漏洞。如果先前的任务是由恶意用户执行的,则攻击者可以使用ansible facts文件选择发送的模块。 2.7.x,2.8.x和2.9.x分支中的所有版本都被认为是易受攻击的。

解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:
https://www.ansible.com/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible * Up to
(including)
2.7.16
运行在以下环境
应用 redhat ansible * From
(including)
2.8.0
Up to
(including)
2.8.8
运行在以下环境
应用 redhat ansible * From
(including)
2.9.0
Up to
(including)
2.9.5
运行在以下环境
应用 redhat ansible_tower * Up to
(including)
3.3.4
运行在以下环境
应用 redhat ansible_tower * From
(including)
3.3.5
Up to
(including)
3.4.5
运行在以下环境
应用 redhat ansible_tower * From
(including)
3.5.0
Up to
(including)
3.5.5
运行在以下环境
应用 redhat ansible_tower * From
(including)
3.6.0
Up to
(including)
3.6.3
运行在以下环境
应用 redhat cloudforms_management_engine 5.0 -
运行在以下环境
应用 redhat openstack 13.0 -
运行在以下环境
系统 debian_10 qemu * Up to
(including)
2.7.7+dfsg-1+deb10u1
运行在以下环境
系统 debian_11 qemu * Up to
(including)
2.10.7+merged+base+2.10.8+dfsg-1
运行在以下环境
系统 debian_12 ansible * Up to
(including)
5.5.0-1
运行在以下环境
系统 debian_9 qemu * Up to
(including)
2.2.1.0-2+deb9u1
运行在以下环境
系统 debian_sid qemu * Up to
(including)
5.5.0-1
运行在以下环境
系统 fedora_EPEL_7 qemu * Up to
(excluding)
2.9.7-1.el7
运行在以下环境
系统 fedora_EPEL_8 qemu * Up to
(excluding)
2.9.7-1.el8
运行在以下环境
系统 opensuse_Leap_15.3 ansible * Up to
(excluding)
5.2.0-17.1
运行在以下环境
系统 ubuntu_16.04.7_lts qemu * Up to
(excluding)
1:2.5+dfsg-5ubuntu10.48
运行在以下环境
系统 ubuntu_18.04.5_lts qemu * Up to
(excluding)
1:2.11+dfsg-1ubuntu7.34
阿里云评分
2.4
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    临时补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-88 参数注入或修改
阿里云安全产品覆盖情况