低危 Ansible 信息泄露漏洞

CVE编号

CVE-2020-1746

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-05-13 07:15:00
漏洞描述
Ansible是美国Ansible公司的一款计算机系统配置管理器。该产品可用于发布、管理和编排计算机系统。Ansible Tower是其中的一个提供了用户界面(UI)、仪表板和REST API的任务控制应用程序。Ansible Engine是其中的一个Ansible引擎。
Ansible中存在信息泄露漏洞。该漏洞源于网络系统或产品在运行过程中存在配置等错误。未授权的攻击者可利用漏洞获取受影响组件敏感信息。以下产品及版本受到影响:Ansible Engine 2.7.17之前的2.7.x版本,2.8.11之前的2.8.x版本,2.9.7之前的2.9.x版本;Ansible Tower 3.4.5及之前版本,3.5.5及之前版本,3.6.3及之前版本。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible_engine * From
(including)
2.7.0
Up to
(excluding)
2.7.17
运行在以下环境
应用 redhat ansible_engine * From
(including)
2.8.0
Up to
(excluding)
2.8.11
运行在以下环境
应用 redhat ansible_engine * From
(including)
2.9.0
Up to
(excluding)
2.9.7
运行在以下环境
应用 redhat ansible_tower * From
(including)
3.4.0
Up to
(including)
3.4.5
运行在以下环境
应用 redhat ansible_tower * From
(including)
3.5.0
Up to
(including)
3.5.5
运行在以下环境
应用 redhat ansible_tower * From
(including)
3.6.0
Up to
(including)
3.6.3
2
运行在以下环境
系统 alpine_3.14 ansible * Up to
(excluding)
2.9.7-r0
3
运行在以下环境
系统 fedora_EPEL_8 ansible * Up to
(excluding)
2.9.7-1.el8
4
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.9.7-1.el7
5
运行在以下环境
系统 debian_10 ansible * Up to
(excluding)
2.7.7+dfsg-1+deb10u1
6
运行在以下环境
系统 alpine_3.11 ansible * Up to
(excluding)
2.9.7-r0
7
运行在以下环境
系统 alpine_3.12 ansible * Up to
(excluding)
2.9.7-r0
8
运行在以下环境
系统 alpine_3.9 ansible * Up to
(excluding)
2.7.17-r0
9
运行在以下环境
系统 alpine_edge ansible * Up to
(excluding)
2.9.7-r0
10
运行在以下环境
系统 alpine_3.13 ansible * Up to
(excluding)
2.9.7-r0
11
运行在以下环境
系统 fedora_32 ansible * Up to
(excluding)
2.9.7-1.fc32
12
运行在以下环境
系统 fedora_EPEL_8 ansible * Up to
(excluding)
2.9.7-1.el8
13
运行在以下环境
系统 fedora_30 ansible * Up to
(excluding)
2.9.7-1.fc30
14
运行在以下环境
系统 fedora_31 ansible * Up to
(excluding)
2.9.7-1.fc31
15
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.9.7-1.el7
16
运行在以下环境
系统 fedora_EPEL_8 ansible * Up to
(excluding)
2.9.7-1.el8
17
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.9.7-1.el7
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-200 信息暴露
阿里云安全产品覆盖情况