低危 kubectl连接插件泄漏敏感信息

CVE编号

CVE-2020-1753

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-03-17 04:15:00
漏洞描述
在使用k8s模块管理kubernetes时,在Ansible Engine中发现了一个安全缺陷,所有Ansible2.7.x版本在2.7.17之前,所有Ansible2.8.x版本在2.8.11之前,所有Ansible2.9.x版本在2.9.7之前。 敏感参数如密码和令牌从命令行传递给kubectl,而不是使用环境变量或输入配置文件。 这将披露来自进程列表的密码和令牌,no_log调试模块的指令将不会产生任何影响,使这些秘密被披露在stdout和日志文件上。
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://github.com/ansible/ansible
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible_engine * Up to
(including)
2.7.16
运行在以下环境
应用 redhat ansible_engine * From
(including)
2.8.0
Up to
(including)
2.8.8
运行在以下环境
应用 redhat ansible_engine * From
(including)
2.9.0
Up to
(including)
2.9.5
运行在以下环境
应用 redhat ansible_tower * Up to
(including)
3.3.4
运行在以下环境
应用 redhat ansible_tower * From
(including)
3.4.0
Up to
(including)
3.4.5
运行在以下环境
应用 redhat ansible_tower * From
(including)
3.5.0
Up to
(including)
3.5.5
运行在以下环境
应用 redhat ansible_tower * From
(including)
3.6.0
Up to
(including)
3.6.3
2
运行在以下环境
系统 unionos_20 ansible * Up to
(excluding)
9.27~dfsg.1-1+dde
3
运行在以下环境
系统 ubuntu_20.04 ansible * Up to
(excluding)
9.50~dfsg-5ubuntu4.2
4
运行在以下环境
系统 ubuntu_18.04 ansible * Up to
(excluding)
9.26~dfsg+0-0ubuntu0.18.04.13
5
运行在以下环境
系统 alpine_3.14 ansible * Up to
(excluding)
9.51-r0
6
运行在以下环境
系统 fedora_EPEL_8 ansible * Up to
(excluding)
2.9.7-1.el8
7
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.9.7-1.el7
8
运行在以下环境
系统 redhat_8 ansible * Up to
(excluding)
9.27-1.el8
9
运行在以下环境
系统 centos_8 ansible * Up to
(excluding)
9.27-1.el8
10
运行在以下环境
系统 oracle_8 ansible * Up to
(excluding)
9.27-1.el8
11
运行在以下环境
系统 fedora_EPEL_8 ansible * Up to
(excluding)
2.9.7-1.el8
12
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.9.7-1.el7
13
运行在以下环境
系统 debian_11 ansible * Up to
(excluding)
2.9.13+dfsg-1
14
运行在以下环境
系统 debian_10 ansible * Up to
(excluding)
9.27~dfsg-2+deb10u4
15
运行在以下环境
系统 debian_sid ansible * Up to
(excluding)
2.9.13+dfsg-1
16
运行在以下环境
系统 alpine_3.13 ansible * Up to
(excluding)
9.51-r0
17
运行在以下环境
系统 debian_9 ansible * Up to
(excluding)
9.26a~dfsg-0+deb9u7
18
运行在以下环境
系统 alpine_edge ansible * Up to
(excluding)
9.51-r0
19
运行在以下环境
系统 fedora_32 ansible * Up to
(excluding)
2.9.7-1.fc32
20
运行在以下环境
系统 fedora_EPEL_8 ansible * Up to
(excluding)
2.9.7-1.el8
21
运行在以下环境
系统 fedora_30 ansible * Up to
(excluding)
2.9.7-1.fc30
22
运行在以下环境
系统 fedora_31 ansible * Up to
(excluding)
2.9.7-1.fc31
23
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.9.7-1.el7
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-200 信息暴露
CWE-214 通过处理环境导致的信息暴露
CWE-532 通过日志文件的信息暴露
阿里云安全产品覆盖情况