低危 Red Hat Ceph安全特征问题漏洞

CVE编号

CVE-2020-1759

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-04-14
漏洞描述
Red Hat Ceph Storage和Red Hat OpenShift都是美国红帽(Red Hat)公司的产品。Red Hat Ceph Storage是一套可扩展的、开放性的软件定义存储平台。Red Hat OpenShift是一款平台即服务(PaaS)云计算平台,它支持构建、测试、部署和运行应用程序。 Red Hat Ceph Storage 4.0版本、OpenStack 15.0版本和Openshift 4.2版本中的messenger v2协议的安全模式存在安全特征问题漏洞。攻击者可利用该漏洞伪造auth标签并可能操纵数据。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://bugzilla.redhat.com/show_bug.cgi?id=1811712
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ceph_storage 4.0 -
运行在以下环境
应用 redhat openshift 4.2 -
运行在以下环境
应用 redhat openstack 15.0 -
运行在以下环境
系统 alpine_3.10 ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 alpine_3.11 ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 alpine_3.12 ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 alpine_3.13 ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 alpine_3.14 ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 alpine_3.15 ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 alpine_3.16 ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 alpine_edge ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 fedora_31 ceph * Up to
(excluding)
14.2.9-1.fc31
运行在以下环境
系统 opensuse_Leap_15.1 ceph * Up to
(excluding)
14.2.5.389
运行在以下环境
系统 unionos_20 ceph * Up to
(excluding)
12.2.11+dfsg1.1-1+dde
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-323 在加密中重用Nonce与密钥对
CWE-330 使用不充分的随机数
阿里云安全产品覆盖情况