低危 Ceph Object Gateway S3 Request 跨站点脚本漏洞

CVE编号

CVE-2020-1760

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-04-24
漏洞描述
在Ceph对象网关中发现了一个漏洞,该漏洞支持Amazon S3中匿名用户发送的请求。由于缺乏对不可信输入的适当中和,此漏洞可能导致潜在的XSS攻击。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://bugzilla.redhat.com/show_bug.cgi?id=1812962
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 linuxfoundation ceph - -
运行在以下环境
应用 redhat ceph_storage 3.0 -
运行在以下环境
应用 redhat ceph_storage 4.0 -
运行在以下环境
应用 redhat openshift_container_platform 4.2 -
运行在以下环境
系统 alpine_3.10 ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 alpine_3.11 ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 alpine_3.12 ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 alpine_3.13 ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 alpine_3.14 ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 alpine_3.15 ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 alpine_edge ceph * Up to
(excluding)
14.2.9-r0
运行在以下环境
系统 centos_8 ceph * Up to
(excluding)
14.2.8-81.el8cp
运行在以下环境
系统 debian_10 ceph * Up to
(including)
12.2.11+dfsg1-2.1
运行在以下环境
系统 debian_8 ceph * Up to
(excluding)
0.80.7-2+deb8u2
运行在以下环境
系统 debian_9 ceph * Up to
(excluding)
10.2.11-2+deb9u1
运行在以下环境
系统 fedora_31 ceph * Up to
(excluding)
14.2.9-1.fc31
运行在以下环境
系统 opensuse_Leap_15.1 ceph * Up to
(excluding)
14.2.5.389
运行在以下环境
系统 redhat_8 ceph * Up to
(excluding)
14.2.8-81.el8cp
运行在以下环境
系统 suse_12 ceph * Up to
(excluding)
12.2.12+git.1585658687.363df3a813-2.42
运行在以下环境
系统 suse_12_SP4 ceph * Up to
(excluding)
12.2.12
运行在以下环境
系统 suse_12_SP5 ceph * Up to
(excluding)
12.2.12
运行在以下环境
系统 ubuntu_16.04 ceph * Up to
(excluding)
10.2.11-0ubuntu0.16.04.3
运行在以下环境
系统 ubuntu_16.04.7_lts ceph * Up to
(excluding)
10.2.11-0ubuntu0.16.04.3
运行在以下环境
系统 ubuntu_18.04 ceph * Up to
(excluding)
12.2.13-0ubuntu0.18.04.4
运行在以下环境
系统 ubuntu_18.04.5_lts ceph * Up to
(excluding)
12.2.13-0ubuntu0.18.04.4
运行在以下环境
系统 unionos_20 ceph * Up to
(excluding)
12.2.11+dfsg1.2-1+dde
阿里云评分
3.7
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况