低危 Apache ActiveMQ跨站脚本漏洞

CVE编号

CVE-2020-1941

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-05-15
漏洞描述
Apache ActiveMQ是美国阿帕奇(Apache)软件基金会的一套开源的消息中间件,它支持Java消息服务、集群、Spring Framework等。
Apache ActiveMQ 5.0.0版本至5.15.11版本中的webconsole admin GUI存在跨站脚本漏洞。该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
http://activemq.apache.org/security-advisories.data/CVE-2020-1941-announcement.txt
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache activemq * From
(including)
5.0.0
Up to
(including)
5.15.11
运行在以下环境
系统 debian_10 activemq * Up to
(including)
5.15.8-2
运行在以下环境
系统 debian_11 activemq * Up to
(including)
5.16.1-1
运行在以下环境
系统 debian_12 activemq * Up to
(including)
5.16.1-1
运行在以下环境
系统 debian_9 activemq * Up to
(including)
5.14.3-3
运行在以下环境
系统 debian_sid activemq * Up to
(including)
5.16.1-2
阿里云评分
3.7
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况