中危 libraw 安全漏洞 (CVE-2020-22628)

CVE编号

CVE-2020-22628

利用情况

暂无

补丁情况

官方补丁

披露时间

2023-08-23
漏洞描述
Buffer Overflow vulnerability in LibRaw::stretch() function in libraw\src\postprocessing\aspect_ratio.cpp.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libraw libraw * Up to
(excluding)
2019-11-20
运行在以下环境
系统 amazon_2 LibRaw * Up to
(excluding)
0.19.4-1.amzn2.0.2
运行在以下环境
系统 debian_10 libraw * Up to
(excluding)
0.19.2-2+deb10u4
运行在以下环境
系统 debian_11 libraw * Up to
(excluding)
0.20.0-4
运行在以下环境
系统 debian_12 libraw * Up to
(excluding)
0.20.0-4
运行在以下环境
系统 opensuse_Leap_15.4 libraw16 * Up to
(excluding)
0.18.9-150000.3.23.1
运行在以下环境
系统 opensuse_Leap_15.5 libraw20 * Up to
(excluding)
0.20.2-150400.3.9.1
运行在以下环境
系统 ubuntu_20.04 libraw * Up to
(excluding)
0.19.5-1ubuntu1.3
阿里云评分
6.1
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况