高危 FasterXML jackson-databind 安全漏洞(CVE-2020-24616)

CVE编号

CVE-2020-24616

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2020-08-26
漏洞描述
2.9.10.6之前的FasterXML jackson databind 2.x错误地处理了序列化小工具和类型之间的交互,与br.com.anteros.dbcp.AnterosDBCPDataSource相关(又名Anteros DBCP)。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/FasterXML/jackson-databind/issues/2814
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 fasterxml jackson-databind * From
(including)
2.0.0
Up to
(excluding)
2.9.10.6
运行在以下环境
系统 debian_10 jackson-databind * Up to
(excluding)
2.9.8-3+deb10u3
运行在以下环境
系统 debian_11 jackson-databind * Up to
(including)
2.11.1-1
运行在以下环境
系统 debian_9 jackson-databind * Up to
(excluding)
2.8.6-1+deb9u9
运行在以下环境
系统 debian_sid jackson-databind * Up to
(including)
2.11.1-1
阿里云评分
8.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-502 可信数据的反序列化
CWE-94 对生成代码的控制不恰当(代码注入)
阿里云安全产品覆盖情况