低危 libxml2缓冲区溢出漏洞

CVE编号

CVE-2020-24977

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-09-04
漏洞描述
libxml2是一款使用C语言编写的用于解析XML文档的函数库。 libxml2 v2.9.10和更早版本的libxml2/entities.c的xmlEncodeEntitiesInternal中存在缓冲区溢出漏洞,该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp active_iq_unified_manager * From
(including)
7.3
运行在以下环境
应用 netapp active_iq_unified_manager * From
(including)
9.5
运行在以下环境
应用 netapp clustered_data_ontap - -
运行在以下环境
应用 netapp clustered_data_ontap_antivirus_connector - -
运行在以下环境
应用 netapp inventory_collect_tool - -
运行在以下环境
应用 netapp manageability_software_development_kit - -
运行在以下环境
应用 netapp snapdrive - -
运行在以下环境
应用 xmlsoft libxml2 2.9.10 -
运行在以下环境
系统 alpine_3.10 libxml2 * Up to
(excluding)
2.9.9-r4
运行在以下环境
系统 alpine_3.11 libxml2 * Up to
(excluding)
2.9.10-r4
运行在以下环境
系统 alpine_3.12 libxml2 * Up to
(excluding)
2.9.10-r5
运行在以下环境
系统 alpine_3.13 libxml2 * Up to
(excluding)
2.9.10-r5
运行在以下环境
系统 alpine_3.14 libxml2 * Up to
(excluding)
2.9.10-r5
运行在以下环境
系统 alpine_3.15 libxml2 * Up to
(excluding)
2.9.10-r5
运行在以下环境
系统 alpine_3.9 libxml2 * Up to
(excluding)
2.9.9-r3
运行在以下环境
系统 alpine_edge libxml2 * Up to
(excluding)
2.9.10-r5
运行在以下环境
系统 amazon_2 libxml2 * Up to
(excluding)
2.9.1-6.amzn2.5.3
运行在以下环境
系统 centos_8 libxml2 * Up to
(excluding)
2.9.7-9.el8
运行在以下环境
系统 debian_10 libxml2 * Up to
(excluding)
2.9.4+dfsg1-7+deb10u2
运行在以下环境
系统 debian_11 libxml2 * Up to
(including)
2.9.10+dfsg-6.1
运行在以下环境
系统 debian_9 libxml2 * Up to
(excluding)
2.9.4+dfsg1-2.2+deb9u3
运行在以下环境
系统 debian_sid libxml2 * Up to
(including)
2.9.10+dfsg-6.1
运行在以下环境
系统 fedora_31 libxml2 * Up to
(excluding)
2.9.10-3.fc31
运行在以下环境
系统 fedora_32 libxml2 * Up to
(excluding)
2.9.10-7.fc32
运行在以下环境
系统 fedora_33 libxml2 * Up to
(excluding)
2.9.10-7.fc33
运行在以下环境
系统 opensuse_Leap_15.1 libxml2 * Up to
(excluding)
2-2.9.7-lp151.5.15.1
运行在以下环境
系统 opensuse_Leap_15.2 libxml2 * Up to
(excluding)
2-2.9.7-lp152.10.3.1
运行在以下环境
系统 oracle_8 libxml2 * Up to
(excluding)
2.9.7-9.0.1.el8
运行在以下环境
系统 redhat_8 libxml2 * Up to
(excluding)
2.9.7-9.el8
运行在以下环境
系统 suse_12_SP5 libxml2 * Up to
(excluding)
2.9.4-46.34.1
运行在以下环境
系统 ubuntu_14.04 libxml2 * Up to
(excluding)
2.9.1+dfsg1-3ubuntu4.13+esm2
运行在以下环境
系统 ubuntu_16.04 libxml2 * Up to
(excluding)
2.9.3+dfsg1-1ubuntu0.7+esm1
运行在以下环境
系统 ubuntu_18.04 libxml2 * Up to
(excluding)
2.9.4+dfsg1-6.1ubuntu1.4
运行在以下环境
系统 ubuntu_18.04.5_lts libxml2 * Up to
(excluding)
2.9.4+dfsg1-6.1ubuntu1.4
运行在以下环境
系统 ubuntu_20.04 libxml2 * Up to
(excluding)
2.9.10+dfsg-5ubuntu0.20.04.1
运行在以下环境
系统 unionos_20 libxml2 * Up to
(excluding)
2.9.4.5-1+dde
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况