低危 Xen输入验证错误漏洞

CVE编号

CVE-2020-25595

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-09-24
漏洞描述
Xen是英国剑桥大学的一款开源的虚拟机监视器产品。该产品能够使不同和不兼容的操作系统运行在同一台计算机上,并支持在运行时进行迁移,保证正常运行并且避免宕机。 在Xen到4.14.x版本中发现一个问题。PCI传递代码未正确使用寄存器数据。Xen的MSI处理中的代码路径已被识别,它们作用于从设备硬件寄存器读回的未初始化值。虽然严格符合PCI规范的设备不应该影响这些寄存器,但经验表明,设备有不符合规范的“后门”操作会影响这些读取的结果,这是非常常见的。不完全信任的客户机可能会使Xen崩溃,从而导致整个系统的拒绝服务(DoS)。不能排除权限提升和信息泄漏。所有支持PCI passthrough的Xen版本都会受到影响。只有x86系统易受攻击。Arm系统不易受攻击。只有具有通过PCI设备的guest才能利用此漏洞。只有通过不符合规范(“后门”)功能的设备的系统才会导致问题。经验表明,这种不符合规范的功能是常见的;除非您有理由相信您的设备不具有此类功能,否则最好假设它具有此类功能。

解决建议

目前厂商已发布升级补丁以修复漏洞,补丁获取链接: https://xenbits.xen.org/xsa/advisory-337.html


受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 alpine_3.10 xen * Up to
(excluding)
4.12.3-r4
运行在以下环境
系统 alpine_3.11 xen * Up to
(excluding)
4.13.1-r4
运行在以下环境
系统 alpine_3.12 xen * Up to
(excluding)
4.13.1-r4
运行在以下环境
系统 alpine_3.13 xen * Up to
(excluding)
4.14.0-r1
运行在以下环境
系统 alpine_3.14 xen * Up to
(excluding)
4.14.0-r1
运行在以下环境
系统 alpine_3.15 xen * Up to
(excluding)
4.14.0-r1
运行在以下环境
系统 alpine_3.16 xen * Up to
(excluding)
4.14.0-r1
运行在以下环境
系统 alpine_3.17 xen * Up to
(excluding)
4.14.0-r1
运行在以下环境
系统 alpine_3.18 xen * Up to
(excluding)
4.14.0-r1
运行在以下环境
系统 alpine_3.9 xen * Up to
(excluding)
4.11.4-r2
运行在以下环境
系统 alpine_edge xen * Up to
(excluding)
4.14.0-r1
运行在以下环境
系统 debian debian_linux 10.0 -
运行在以下环境
系统 debian_10 xen * Up to
(excluding)
4.11.4+37-g3263f257ca-1
运行在以下环境
系统 debian_11 xen * Up to
(excluding)
4.14.0+80-gd101b417b7-1
运行在以下环境
系统 debian_12 xen * Up to
(excluding)
4.14.0+80-gd101b417b7-1
运行在以下环境
系统 debian_9 xen * Up to
(including)
4.8.5.final+shim4.10.4-1+deb9u12
运行在以下环境
系统 debian_sid xen * Up to
(excluding)
4.14.0+80-gd101b417b7-1
运行在以下环境
系统 fedoraproject fedora 32 -
运行在以下环境
系统 fedoraproject fedora 33 -
运行在以下环境
系统 fedora_31 xen-hypervisor * Up to
(excluding)
4.12.3-5.fc31
运行在以下环境
系统 fedora_32 xen-hypervisor * Up to
(excluding)
4.13.1-6.fc32
运行在以下环境
系统 fedora_33 xen-hypervisor * Up to
(excluding)
4.14.0-5.fc33
运行在以下环境
系统 opensuse leap 15.2 -
运行在以下环境
系统 opensuse_Leap_15.2 xen-libs * Up to
(excluding)
4.13.1_08-lp152.2.9.1
运行在以下环境
系统 suse_12_SP5 xen * Up to
(excluding)
4.12.3_08-3.24.1
运行在以下环境
系统 ubuntu_20.04 xen * Up to
(excluding)
4.11.3+24-g14b62ab3e5-1ubuntu2.3
运行在以下环境
系统 xen xen * Up to
(including)
4.14.0
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-269 特权管理不恰当
阿里云安全产品覆盖情况