低危 Django跨站脚本漏洞

CVE编号

CVE-2020-25626

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-10-01
漏洞描述
Django是Django基金会的一套基于Python语言的开源Web应用框架。该框架包括面向对象的映射器、视图系统、模板系统等。 Django 中存在跨站脚本漏洞。该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。

解决建议

目前厂商已发布升级补丁以修复漏洞,补丁获取链接: https://bugzilla.redhat.com/show_bug.cgi?id=1878635


受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 encode django_rest_framework * Up to
(excluding)
3.12.0
运行在以下环境
应用 redhat ceph_storage 2.0 -
运行在以下环境
系统 debian_10 djangorestframework * Up to
(excluding)
3.9.0-1
运行在以下环境
系统 debian_11 djangorestframework * Up to
(excluding)
3.11.0-1
运行在以下环境
系统 debian_9 djangorestframework * Up to
(excluding)
3.4.0-2
运行在以下环境
系统 opensuse_Leap_15.2 djangorestframework * Up to
(excluding)
3.11.2-lp152.2.3.1
阿里云评分
3.7
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况