中危 linux linux_kernel 空指针解引用

CVE编号

CVE-2020-25639

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-03-05
漏洞描述
A NULL pointer dereference flaw was found in the Linux kernel's GPU Nouveau driver functionality in versions prior to 5.12-rc1 in the way the user calls ioctl DRM_IOCTL_NOUVEAU_CHANNEL_ALLOC. This flaw allows a local user to crash the system.
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:
https://bugzilla.redhat.com/show_bug.cgi?id=1876995
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat openshift_container_platform 4.4 -
运行在以下环境
应用 redhat openshift_container_platform 4.5 -
运行在以下环境
应用 redhat openshift_container_platform 4.6 -
运行在以下环境
系统 amazon_2 kernel * Up to
(excluding)
5.4.105-48.177.amzn2
运行在以下环境
系统 fedoraproject fedora 32 -
运行在以下环境
系统 fedoraproject fedora 33 -
运行在以下环境
系统 fedora_32 kernel * Up to
(excluding)
5.10.20-100.fc32
运行在以下环境
系统 fedora_33 kernel * Up to
(excluding)
5.10.20-200.fc33
运行在以下环境
系统 linux linux_kernel * Up to
(including)
5.11.2
运行在以下环境
系统 opensuse_Leap_15.1 kernel * Up to
(excluding)
4.12.14-lp151.28.91.1
运行在以下环境
系统 opensuse_Leap_15.2 kernel * Up to
(excluding)
5.3.18-lp152.60.1
运行在以下环境
系统 oracle linux_7 kernel * Up to
(excluding)
5.4.17-2102.200.13.el7
运行在以下环境
系统 oracle linux_8 kernel * Up to
(excluding)
5.4.17-2102.200.13.el8
运行在以下环境
系统 oracle_7 kernel * Up to
(excluding)
5.4.17-2102.200.13.el7
运行在以下环境
系统 oracle_8 kernel * Up to
(excluding)
5.4.17-2102.200.13.el8
运行在以下环境
系统 redhat enterprise_linux 5.0 -
运行在以下环境
系统 redhat enterprise_linux 6.0 -
运行在以下环境
系统 redhat enterprise_linux 7.0 -
运行在以下环境
系统 redhat enterprise_linux 8.0 -
运行在以下环境
系统 redhat messaging_realtime_grid 2.0 -
运行在以下环境
系统 sles_12_SP5 kernel * Up to
(excluding)
4.12.14-16.44.1
运行在以下环境
系统 suse_12_SP5 kernel * Up to
(excluding)
4.12.14-16.44.1
运行在以下环境
系统 ubuntu_16.04.7_lts linux * Up to
(excluding)
4.2.0-16.19
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.2.0-16.19
运行在以下环境
系统 ubuntu_18.04 kernel * Up to
(excluding)
5.4.0-1047.49~18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts linux * Up to
(excluding)
4.13.0-16.19
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.13.0-16.19
运行在以下环境
系统 ubuntu_20.04 kernel * Up to
(excluding)
5.4.0-1043.45
运行在以下环境
系统 ubuntu_21.10 kernel * Up to
(excluding)
5.11.0-1006.6
阿里云评分
4.2
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-476 空指针解引用
阿里云安全产品覆盖情况