低危 OpenLDAP for Ubuntu拒绝服务漏洞

CVE编号

CVE-2020-25692

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-12-08
漏洞描述
OpenLDAP是美国OpenLDAP基金会的一个轻型目录访问协议(LDAP)的开源实现。 在重命名RDN的请求期间,在OpenLDAP服务器中找到了NULL指针取消引用,并在openldap 2.4.55中修复了该问题。未经身份验证的攻击者可以通过发送经特殊设计的请求来远程破坏slapd进程,从而导致拒绝服务。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:https://git.openldap.org/openldap/openldap/-/commit/a08a2db4063f54a6217a0f091aebd02f8bdb482e;https://git.openldap.org/openldap/openldap/-/commit/6abfd60078af02d56edb3b6897692cdd09a08971
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openldap openldap * Up to
(excluding)
2.4.55
运行在以下环境
系统 alibaba_cloud_linux_2.1903 openldap * Up to
(excluding)
2.4.44-23.1.al7
运行在以下环境
系统 alpine_3.10 openldap * Up to
(excluding)
2.4.48-r2
运行在以下环境
系统 alpine_3.11 openldap * Up to
(excluding)
2.4.48-r3
运行在以下环境
系统 alpine_3.12 openldap * Up to
(excluding)
2.4.50-r1
运行在以下环境
系统 alpine_3.9 openldap * Up to
(excluding)
2.4.48-r2
运行在以下环境
系统 amazon_2 openldap * Up to
(excluding)
2.4.44-23.amzn2
运行在以下环境
系统 debian_10 openldap * Up to
(excluding)
2.4.47+dfsg-3+deb10u3
运行在以下环境
系统 debian_11 openldap * Up to
(excluding)
2.4.55+dfsg-1
运行在以下环境
系统 debian_12 openldap * Up to
(excluding)
2.4.55+dfsg-1
运行在以下环境
系统 debian_9 openldap * Up to
(excluding)
2.4.44+dfsg-5+deb9u5
运行在以下环境
系统 kylinos_aarch64_V10 openldap * Up to
(excluding)
2.4.44-23.el7_9
运行在以下环境
系统 kylinos_aarch64_V10SP1 openldap * Up to
(excluding)
2.4.50-7.ky10
运行在以下环境
系统 kylinos_loongarch64_V10SP1 openldap * Up to
(excluding)
2.4.50-7.a.ky10
运行在以下环境
系统 kylinos_x86_64_V10 openldap * Up to
(excluding)
2.4.44-23.el7_9
运行在以下环境
系统 kylinos_x86_64_V10SP1 openldap * Up to
(excluding)
2.4.50-7.ky10
运行在以下环境
系统 kylinos_x86_64_V10SP2 openldap * Up to
(excluding)
2.4.50-7.ky10
运行在以下环境
系统 opensuse_Leap_15.1 openldap2 * Up to
(excluding)
2.4.46-lp151.10.21.1
运行在以下环境
系统 opensuse_Leap_15.2 openldap2 * Up to
(excluding)
2.4.46-lp152.14.12.1
运行在以下环境
系统 oracle_7 openldap * Up to
(excluding)
2.4.44-23.el7_9
运行在以下环境
系统 redhat_7 openldap * Up to
(excluding)
2.4.44-23.el7_9
运行在以下环境
系统 suse_12_SP5 openldap2 * Up to
(excluding)
2.4.41-18.77.1
运行在以下环境
系统 ubuntu_16.04 openldap * Up to
(excluding)
2.4.42+dfsg-2ubuntu3.10
运行在以下环境
系统 ubuntu_18.04 openldap * Up to
(excluding)
2.4.45+dfsg-1ubuntu1.7
运行在以下环境
系统 ubuntu_20.04 openldap * Up to
(excluding)
2.4.49+dfsg-2ubuntu1.4
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-476 空指针解引用
阿里云安全产品覆盖情况