低危 OpenLDAP Certificate List Syntax拒绝服务漏洞

CVE编号

CVE-2020-25709

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-05-18
漏洞描述
OpenLDAP是美国OpenLDAP基金会的一个轻型目录访问协议(LDAP)的开源实现。

OpenLDAP Certificate List Syntax存在拒绝服务漏洞,攻击者可利用该漏洞可以通过强制断言错误,从而触发拒绝服务。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://www.debian.org/security/2020/dsa-4792
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openldap openldap * Up to
(excluding)
2.4.56
运行在以下环境
应用 redhat jboss_core_services - -
运行在以下环境
系统 alpine_3.10 openldap * Up to
(excluding)
2.4.48-r2
运行在以下环境
系统 alpine_3.11 openldap * Up to
(excluding)
2.4.48-r3
运行在以下环境
系统 alpine_3.12 openldap * Up to
(excluding)
2.4.50-r1
运行在以下环境
系统 alpine_3.13 openldap * Up to
(excluding)
2.4.56-r0
运行在以下环境
系统 alpine_3.14 openldap * Up to
(excluding)
2.4.56-r0
运行在以下环境
系统 alpine_3.15 openldap * Up to
(excluding)
2.4.56-r0
运行在以下环境
系统 alpine_3.9 openldap * Up to
(excluding)
2.4.48-r2
运行在以下环境
系统 alpine_edge openldap * Up to
(excluding)
2.4.56-r0
运行在以下环境
系统 debian_10 openldap * Up to
(excluding)
2.4.47+dfsg-3+deb10u4
运行在以下环境
系统 debian_11 openldap * Up to
(excluding)
2.4.55+dfsg-1
运行在以下环境
系统 debian_9 openldap * Up to
(excluding)
2.4.44+dfsg-5+deb9u6
运行在以下环境
系统 opensuse_Leap_15.1 openldap * Up to
(excluding)
2.4.46-lp151.10.24.1
运行在以下环境
系统 opensuse_Leap_15.2 openldap * Up to
(excluding)
2.4.46-lp152.14.15.1
运行在以下环境
系统 suse_12_SP5 openldap * Up to
(excluding)
2.4.41-18.80.1
运行在以下环境
系统 ubuntu_14.04 openldap * Up to
(excluding)
2.4.31-1+nmu2ubuntu8.5+esm4
运行在以下环境
系统 ubuntu_14.04.6_lts openldap * Up to
(excluding)
2.4.31-1+nmu2ubuntu8.5+esm4
运行在以下环境
系统 ubuntu_16.04 openldap * Up to
(excluding)
2.4.42+dfsg-2ubuntu3.11
运行在以下环境
系统 ubuntu_16.04.7_lts openldap * Up to
(excluding)
2.4.42+dfsg-2ubuntu3.11
运行在以下环境
系统 ubuntu_18.04 openldap * Up to
(excluding)
2.4.45+dfsg-1ubuntu1.8
运行在以下环境
系统 ubuntu_18.04.5_lts openldap * Up to
(excluding)
2.4.45+dfsg-1ubuntu1.8
运行在以下环境
系统 ubuntu_20.04 openldap * Up to
(excluding)
2.4.49+dfsg-2ubuntu1.5
运行在以下环境
系统 unionos_20 openldap * Up to
(excluding)
2.4.47+dfsg.2-1+eagle
阿里云评分
3.6
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-617 可达断言
阿里云安全产品覆盖情况