低危 phpMyAdmin SQL注入漏洞

CVE编号

CVE-2020-26935

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-10-11
漏洞描述
phpMyAdmin是phpMyAdmin团队的一套免费的、基于Web的MySQL数据库管理工具。该工具能够创建和删除数据库,创建、删除、修改数据库表,执行SQL脚本命令等。 phpMyAdmin 4.9.6之前版本,SearchController 5.0.3之前版本存在SQL注入漏洞,该漏洞允许攻击者进行SQL注入攻击。

解决建议

目前厂商已发布升级补丁以修复漏洞,补丁获取链接: https://github.com/phpmyadmin/phpmyadmin/commit/d09ab9bc9d634ad08b866d42bb8c4109869d38d2


受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 opensuse backports_sle 15.0 -
运行在以下环境
应用 phpmyadmin phpmyadmin * From
(including)
4.9.0
Up to
(excluding)
4.9.6
运行在以下环境
应用 phpmyadmin phpmyadmin * From
(including)
5.0.0
Up to
(excluding)
5.0.3
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian_9 phpMyAdmin * Up to
(excluding)
4:4.6.6-4+deb9u2
运行在以下环境
系统 fedoraproject fedora 31 -
运行在以下环境
系统 fedoraproject fedora 32 -
运行在以下环境
系统 fedoraproject fedora 33 -
运行在以下环境
系统 fedora_31 phpMyAdmin * Up to
(excluding)
5.0.3-1.fc31
运行在以下环境
系统 fedora_32 phpMyAdmin * Up to
(excluding)
5.0.3-1.fc32
运行在以下环境
系统 fedora_33 phpMyAdmin * Up to
(excluding)
5.0.3-1.fc33
运行在以下环境
系统 opensuse_Leap_15.1 phpMyAdmin * Up to
(excluding)
4.9.7-52.1
运行在以下环境
系统 opensuse_Leap_15.2 phpMyAdmin * Up to
(excluding)
4.9.6-46.1
运行在以下环境
系统 ubuntu_18.04 phpMyAdmin * Up to
(excluding)
4:4.6.6-5ubuntu0.5
运行在以下环境
系统 ubuntu_18.04.5_lts phpmyadmin * Up to
(excluding)
4:4.6.6-5ubuntu0.5
运行在以下环境
系统 ubuntu_18.04_lts phpmyadmin * Up to
(excluding)
4:4.6.6-5ubuntu0.5
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-89 SQL命令中使用的特殊元素转义处理不恰当(SQL注入)
阿里云安全产品覆盖情况